Bug 110463 - SKL. Textures are flickering in SuperTuxKart
Summary: SKL. Textures are flickering in SuperTuxKart
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-17 13:23 UTC by Denis
Modified: 2019-08-12 11:29 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis 2019-04-17 13:23:05 UTC
Original report and attachments were added by Mark here:
https://bugs.freedesktop.org/show_bug.cgi?id=110395

Short description (full history can be found also there, in original ticket):


When I run supertuxcart on skl, I see lots of flickering.  See attached video.  Curiously, I had to take a video of it with my phone, because the flickering *stops* when I enable gnome's screen recording (ctrl-alt-shift-r).

The non-flickering video is also attached for reference.

Danylo's patch has no affect on this behavior.
Comment 1 Denis 2019-08-08 15:05:46 UTC
Hi Mark, Horst Schirmeier, may I ask you to re-check please this issue on SKL? We couldn't reproduce it from our side even that time when it flickered for you, so would be great to be sure that fix works.



commit bc612536eb2f0f77725103e53077ad5a28036ac3 (HEAD -> master, origin/master, origin/HEAD)
Author: Jason Ekstrand <jason@jlekstrand.net>
Date:   Wed Jul 31 10:42:24 2019 -0500

    anv: Emit a dummy MEDIA_VFE_STATE before switching from GPGPU to 3D
    
    There is an object-level  preemption workaround which requires this.
    However, even without object-level preemption, we seem to have issues
    with geometry flickering when 3D and compute are combined in the same
    batch and this appears to fix it.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=109630
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=111267
    Cc: mesa-stable@lists.freedesktop.org
    Reviewed-by: Kenneth Graunke <kenneth@whitecape.org>


Tested mesa-master with the commit on my CFL (checked on attached apitrace). Works without flickers now.
Comment 2 Denis 2019-08-08 15:08:41 UTC
I am sorry, previous comment was related to ANV fix.

Current issue (for i965) should be fixed with this one:

commit b8842bc3128a255677a1a8ea5207df46f8e54a04
Author: Danylo Piliaiev <danylo.piliaiev@globallogic.com>
Date:   Thu Aug 1 13:57:14 2019 +0300

    i965: Emit a dummy MEDIA_VFE_STATE before switching from GPGPU to 3D
    
    There is an object-level  preemption workaround which requires this.
    However, even without object-level preemption, we seem to have issues
    with geometry flickering when 3D and compute are combined in the same
    batch and this appears to fix it.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=110395
    Suggested-by: Jason Ekstrand <jason@jlekstrand.net>
    Signed-off-by: Danylo Piliaiev <danylo.piliaiev@globallogic.com>
    Reviewed-by: Kenneth Graunke <kenneth@whitecape.org>
    Cc: mesa-stable@lists.freedesktop.org
Comment 3 Mark Janes 2019-08-10 02:25:25 UTC
I can verify that the flickering is fixed by b8842bc3128a255677a1a8ea5207df46f8e54a04.

Would it be possible to write a piglit test to detect this issue?  since several titles were broken...
Comment 4 Denis 2019-08-12 11:29:07 UTC
thanks for checking! We are working on test into piglit


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.