Bug 110476 - Overwatch - some objects are rendered incorrectly
Summary: Overwatch - some objects are rendered incorrectly
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/radeon (show other bugs)
Version: git
Hardware: Other Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-20 17:45 UTC by Danylo
Modified: 2019-04-23 06:55 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
bad rendering example (986.62 KB, image/png)
2019-04-20 17:45 UTC, Danylo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Danylo 2019-04-20 17:45:53 UTC
Created attachment 144051 [details]
bad rendering example

After some Overwatch update some objects are rendered incorrectly - when moving camera it looks like part of current/previous frame are in their place.

Easily seen with palms in the "Loot Box" menu.

 GPU: R9 380X, initially as found by other user with 580
 Driver: Mesa 19.0.0 - 19.1.0-devel (git-f9c594cdf5), LLVM 9.0.0
 Wine version: 4.6
 DXVK version: 0.80 - 1.0.3

Didn't test llvm 8, didn't test mesa below 19.0.0

Renderdoc capture: https://mega.nz/#!VQdzwATa!1fvb5PtQHcPzZpMFz3UzYzq_Le_60uthJ8E8Mq_b9Ls

There is a reason to believe that there is no such issue with LLVM8 since it is reported that it renders correctly with RX580, LLVM8 and mesa 19.0.2

Probably not a DXVK issue but here is an issue filed there: https://github.com/doitsujin/dxvk/issues/1022
Comment 1 Samuel Pitoiset 2019-04-21 18:07:08 UTC
I can reproduce the issue, I will investigate.
Thanks for the report!
Comment 2 Samuel Pitoiset 2019-04-21 19:56:36 UTC
LLVM r356956 introduced the regression. I reported the problem to the compiler team. I will let you know when it's fixed.
Comment 3 Danylo 2019-04-21 20:07:57 UTC
Great, thank you.
Comment 4 Samuel Pitoiset 2019-04-23 06:55:41 UTC
Fixed with LLVM r358890.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.