Bug 110496 - [GLK] no signal - with samsung 4k TV - HDMI UHD Color (ENABLED)
Summary: [GLK] no signal - with samsung 4k TV - HDMI UHD Color (ENABLED)
Status: ASSIGNED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) All
: high normal
Assignee: shashank.sharma@intel.com
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged, ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-22 16:26 UTC by Piotr Kasp.
Modified: 2019-09-06 06:29 UTC (History)
5 users (show)

See Also:
i915 platform: GLK
i915 features: display/HDMI


Attachments
NUC with UHD color enabled at 1080p then I switch resolution to 4k (994.50 KB, text/plain)
2019-04-22 16:26 UTC, Piotr Kasp.
no flags Details
4k@60 enabling hacks (1.23 KB, patch)
2019-04-29 11:45 UTC, shashank.sharma@intel.com
no flags Details | Splinter Review
4k@60 enabling hacks (892 bytes, patch)
2019-04-29 11:46 UTC, shashank.sharma@intel.com
no flags Details | Splinter Review
edid-samsung(QLED)-disbaled_HDR_support (7.35 KB, text/rtf)
2019-05-31 21:26 UTC, Piotr Kasp.
no flags Details
edid-samsung(QLED)-enabled_HDR_support (7.33 KB, text/rtf)
2019-05-31 21:29 UTC, Piotr Kasp.
no flags Details
drm_debug_HDR_enabled.log (1.73 MB, text/plain)
2019-05-31 21:35 UTC, Piotr Kasp.
no flags Details
drm_debug_HDR_disabled.log (966.53 KB, text/plain)
2019-05-31 21:36 UTC, Piotr Kasp.
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kasp. 2019-04-22 16:26:20 UTC
Created attachment 144072 [details]
NUC with UHD color enabled at 1080p then I switch resolution to 4k

Hi
For some reason on Gemini Lake NUC - NUC7CJYH
Latest DRM-tip kernel - latest firmware in Samsung QLED 2018
There is no signal if "HDMI UHD color" is enabled for HDMI where is NUC connected


Here log where is HDMI UHD Color enabled (no signal on TV)
http://ix.io/1GSD

Here where HDMI UHD Color is Disable (no problem)
http://ix.io/1GSG


I Discover its working when is UHD color Enabled and 1080p resolution 
but when you switch to 4k signal gone :( 
I Attached log where I boot NUC with UHD color enabled at 1080p then I switch resolution to 4k and signal gone




EDID: http://ix.io/1GSV
Comment 1 Ville Syrjala 2019-04-23 14:30:13 UTC
Please attach logs/etc. directly to the bug. Otherwise they may be lost and then the bug report is useless.
Comment 2 Lakshmi 2019-04-29 05:27:09 UTC
@Ram, any comments here?
Comment 3 Ramalingam C 2019-04-29 05:54:59 UTC
@lakshmi,
Based on the observations shared, for me it looks like an issue with deep color at 4k. Ville might have insight into this issue.
Comment 4 Ramalingam C 2019-04-29 11:13:06 UTC
@shashank for analyzing the issue. Adding him for the comment here.
Comment 5 shashank.sharma@intel.com 2019-04-29 11:45:16 UTC
Created attachment 144106 [details] [review]
4k@60 enabling hacks
Comment 6 shashank.sharma@intel.com 2019-04-29 11:46:09 UTC
Created attachment 144107 [details] [review]
4k@60 enabling hacks
Comment 7 shashank.sharma@intel.com 2019-04-29 11:46:18 UTC
I was working with Piotr in a parallel thread, and I could root cause the problem while handling deep color stuff.
- When we allow the CMDB modes to be treated as 4:2:0 modes (rather than RGB) && - we don't allow the deep color output (12 BPC)
we could see both 4k@30 and 4k@60 displays. 

I will add some more findings here. Meanwhile, adding patches which we used to enable 4k@60.
Comment 8 Piotr Kasp. 2019-05-29 19:41:16 UTC
there are any news ? or something what we can test it ?
Comment 9 shashank.sharma@intel.com 2019-05-31 06:22:56 UTC
There are 2 new patches merged in drm-tip with which we are able to see 4k@60 outputs on both GLK and ICL. Can we please confirm this observation ? 

- Shashank
Comment 10 Piotr Kasp. 2019-05-31 21:26:30 UTC
Created attachment 144399 [details]
edid-samsung(QLED)-disbaled_HDR_support
Comment 11 Piotr Kasp. 2019-05-31 21:29:18 UTC
Created attachment 144400 [details]
edid-samsung(QLED)-enabled_HDR_support
Comment 12 Piotr Kasp. 2019-05-31 21:33:12 UTC
ok I tested latest drm-tim from today and nothing was fixed :(
yes 4k@50 or 60 working but with disabled HDR (what samsung calling UHD colors)

I attached for other 2 EDID (sorry by mistake thay had opposite name enabled actual I disabled etc.)

and I will attach 2 logs - one with enabled and one with disabled HDR support on TV
Comment 13 Piotr Kasp. 2019-05-31 21:35:15 UTC
Created attachment 144401 [details]
drm_debug_HDR_enabled.log
Comment 14 Piotr Kasp. 2019-05-31 21:36:50 UTC
Created attachment 144402 [details]
drm_debug_HDR_disabled.log
Comment 15 shashank.sharma@intel.com 2019-06-05 14:29:05 UTC
from the logs, I can see:
extended colorimetry: xvYCC 601 

Can you please set the following property and try again:
- output colorspace: BT2020_RGB

- Shashank
Comment 16 sergey79 2019-07-06 23:10:22 UTC
Any news on this (or patches I can try)? I'm having exactly the same issue with my Asrock J4105 Gemini Lake ITX board and Samsung UE40NU7100 TV.
Comment 17 Lakshmi 2019-07-15 06:13:44 UTC
Piotr, Have you tried Shashank's proposal?
Comment 18 sergey79 2019-07-16 03:28:34 UTC
I tried to switch the colorspace to BT2020_RGB using "proptest -M i915 -D /dev/dri/card0 127 connector 131 9". This did not make any difference, still no signal.
Comment 19 sergey79 2019-07-16 16:01:36 UTC
The other thing I noticed is that when Samsung's "HDMI UHD Color" is enabled - I get "no signal" before the OS is booted, e.g. I cannot see the UEFI setup interface.
However, within the OS I get a signal with any video mode except 4K modes (even 3820x2160 @24Hz does not work).
Comment 20 sergey79 2019-08-04 04:28:50 UTC
I did more testing and this seem to be an issue with 12 BPC mode @4k resolutions. If I set the "max bpc" with proptest to 8-bit - I get a signal. No signal with any 12-bit 4k modes (including 24hz).

I want to test with 10-bit instead of 12 but I have no idea how enable the 10 bpc mode. If I limit max bpc with proptest to 10-bit - I get max 8-bit.
Comment 21 shashank.sharma@intel.com 2019-08-05 03:49:01 UTC
I can see in intel_hdmi_deep_color_possible() that we are allowing 10bpc only for GEN11(ICL) onwards.

if (bpc == 10 && INTEL_GEN(dev_priv) < 11)
                return false;
This means we can't (legally) check 10bpc on GLK.

I am suspecting that this Samsung monitor is expecting something different in it's UHD deep color mode, coz I am not able to reproduce this issue with any of the UHD/HDR monitors available with me (LG, Philips). Unfortunately, this issue can't be worked upon without this particular monitor.

- Shashank
Comment 22 sergey79 2019-08-05 15:52:37 UTC
I removed the GEN11 restriction for 10-bit and I can confirm that it doesn't work - no signal with anything above 1080p/24.
Comment 23 shashank.sharma@intel.com 2019-08-05 15:54:54 UTC
Hey,
Actually the check is there because the HW can't support this before ICL, so it is expected.

- Shashank
Comment 24 sergey79 2019-08-25 02:34:41 UTC
I did some more testing and I was wrong about 12-bit color. The issue is not limited to 12-bit modes. RGB 8-bit 4k @60Hz does not work either.

Looks like the issue has something to do with the HDMI link speed. All modes that require the link speed of > 9.0Gbps don't work.

Is it possible to force the driver to use YCbCr 422 12-bit instead of RGB 8-bit for 24-30Hz 4K modes? This should give a better quality/less color banding when watching videos encoded in 10-bit.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.