Bug 110564 - [CI][DRMTIP] igt@gem_eio@in-flight-internal-1us - fail - Failed assertion: !wedged
Summary: [CI][DRMTIP] igt@gem_eio@in-flight-internal-1us - fail - Failed assertion: !w...
Status: CLOSED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-30 11:30 UTC by Lakshmi
Modified: 2019-08-13 13:50 UTC (History)
1 user (show)

See Also:
i915 platform: GLK
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-04-30 11:30:02 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_270/fi-glk-dsi/igt@gem_eio@in-flight-internal-1us.html

gem_eio:1099) igt_gt-CRITICAL: Failed assertion: !wedged
Test gem_eio failed.
**** DEBUG ****
(gem_eio:1099) igt_core-INFO: IGT-Version: 1.23-gcaed2519 (x86_64) (Linux: 5.1.0-rc7-g7aa7357fd0cc-drmtip_270+ x86_64)
(gem_eio:1099) igt_core-DEBUG: Test requirement passed: !igt_run_in_simulation()
(gem_eio:1099) drmtest-DEBUG: Test requirement passed: !(fd<0)
(gem_eio:1099) igt_debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(gem_eio:1099) i915/gem_submission-INFO: Using Execlists submission
(gem_eio:1099) drmtest-DEBUG: Test requirement passed: is_i915_device(fd) && has_known_intel_chipset(fd)
(gem_eio:1099) igt_debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(gem_eio:1099) ioctl_wrappers-DEBUG: Test requirement passed: dir >= 0
(gem_eio:1099) ioctl_wrappers-DEBUG: Test requirement passed: err == 0
(gem_eio:1099) drmtest-DEBUG: Test requirement passed: is_i915_device(fd) && has_known_intel_chipset(fd)
(gem_eio:1099) igt_debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(gem_eio:1099) ioctl_wrappers-DEBUG: Test requirement passed: dir >= 0
(gem_eio:1099) ioctl_wrappers-DEBUG: Test requirement passed: err == 0
(gem_eio:1099) i915/gem_context-DEBUG: Test requirement passed: has_ban_period || has_bannable
(gem_eio:1099) igt_gt-DEBUG: Test requirement passed: has_gpu_reset(fd)
(gem_eio:1099) igt_gt-DEBUG: Test requirement passed: igt_sysfs_set_parameter (fd, "reset", "%d", INT_MAX )
(gem_eio:1099) DEBUG: Enabling GPU reset
(gem_eio:1099) DEBUG: Test requirement passed: fd >= 0
(gem_eio:1099) DEBUG: Test requirement passed: i915_reset_control(true)
(gem_eio:1099) igt_gt-DEBUG: Triggering GPU reset
(gem_eio:1099) igt_debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(gem_eio:1099) igt_gt-CRITICAL: Test assertion failure function igt_force_gpu_reset, file ../lib/igt_gt.c:374:
(gem_eio:1099) igt_gt-CRITICAL: Failed assertion: !wedged
(gem_eio:1099) igt_core-INFO: Stack trace:
(gem_eio:1099) igt_core-INFO:   #0 ../lib/igt_core.c:1476 __igt_fail_assert()
(gem_eio:1099) igt_core-INFO:   #1 ../lib/igt_gt.c:375 igt_force_gpu_reset()
(gem_eio:1099) igt_core-INFO:   #2 ../tests/i915/gem_eio.c:829 __real_main814()
(gem_eio:1099) igt_core-INFO:   #3 ../tests/i915/gem_eio.c:814 main()
(gem_eio:1099) igt_core-INFO:   #4 ../csu/libc-start.c:344 __libc_start_main()
(gem_eio:1099) igt_core-INFO:   #5 [_start+0x2a]
****  END  ****
Subtest in-flight-internal-1us: FAIL
Comment 1 CI Bug Log 2019-04-30 11:30:27 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* GLK: igt@gem_eio@in-flight-internal-1us - fail - Failed assertion: !wedged
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_270/fi-glk-dsi/igt@gem_eio@in-flight-internal-1us.html
Comment 2 Chris Wilson 2019-04-30 12:55:35 UTC
That looks like the machine wasn't happy with the leftover display state, with mmio being slow across the test.
Comment 3 Francesco Balestrieri 2019-06-03 06:51:46 UTC
Only once in a month, itching to close this but let's still wait.
Comment 4 Francesco Balestrieri 2019-07-23 09:00:25 UTC
Scratching the itch.
Comment 5 Lakshmi 2019-08-13 13:50:05 UTC
Closing and archiving as this issue occurred only once drmtip_270 (3 months, 2 weeks old).
Comment 6 CI Bug Log 2019-08-13 13:50:13 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.