Bug 110577 - [CI][DRMTIP] igt@kms_invalid_dotclock - skip - No suitable connectors found, SKIP
Summary: [CI][DRMTIP] igt@kms_invalid_dotclock - skip - No suitable connectors found,...
Status: RESOLVED NOTABUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-02 06:22 UTC by Lakshmi
Modified: 2019-10-01 12:24 UTC (History)
1 user (show)

See Also:
i915 platform: CFL, TGL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-05-02 06:22:16 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_268/fi-cml-u/igt@kms_invalid_dotclock.html
	
IGT-Version: 1.23-gcaed2519 (x86_64) (Linux: 5.1.0-rc6-g18a6fb79860b-drmtip_268+ x86_64)
Max dotclock: 675000 kHz
Test requirement not met in function test, file ../tests/kms_invalid_dotclock.c:104:
Test requirement: valid_connectors
No suitable connectors found
SKIP (0.305s)
Comment 2 Lakshmi 2019-05-02 06:25:55 UTC
On fi-cml-u2 this test is passing on last two rounds (drmtip_272 and drmtip_271), but skips on fi-cml-u, re-cml-u.

This is fixed on fi-cml-u2? On fi-cml-u, skip is expected?
Comment 3 CI Bug Log 2019-09-11 11:00:07 UTC
A CI Bug Log filter associated to this bug has been updated:

{- CML: igt@kms_invalid_dotclock - skip - No suitable connectors found, SKIP -}
{+ CML fi-tgl-u re-tgl-u: igt@kms_invalid_dotclock - skip - No suitable connectors found, SKIP +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_365/fi-tgl-u/igt@kms_invalid_dotclock.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_362/fi-tgl-u/igt@kms_invalid_dotclock.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@kms_invalid_dotclock.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@kms_invalid_dotclock.html
Comment 4 CI Bug Log 2019-09-17 11:45:39 UTC
A CI Bug Log filter associated to this bug has been updated:

{- CML fi-tgl-u re-tgl-u: igt@kms_invalid_dotclock - skip - No suitable connectors found, SKIP -}
{+ CML fi-tgl-u fi-tgl-u2 re-tgl-u: igt@kms_invalid_dotclock - skip - No suitable connectors found, SKIP +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u2/igt@kms_invalid_dotclock.html
Comment 5 CI Bug Log 2019-09-27 07:15:09 UTC
A CI Bug Log filter associated to this bug has been updated:

{- CML fi-tgl-u fi-tgl-u2 re-tgl-u: igt@kms_invalid_dotclock - skip - No suitable connectors found, SKIP -}
{+ CML TGL: igt@kms_invalid_dotclock - skip - No suitable connectors found, SKIP +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6960/shard-tglb3/igt@kms_invalid_dotclock.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6961/shard-tglb2/igt@kms_invalid_dotclock.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6963/re-tgl1-display/igt@kms_invalid_dotclock.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6962/shard-tglb1/igt@kms_invalid_dotclock.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6963/shard-tglb2/igt@kms_invalid_dotclock.html
Comment 6 Karthik B S 2019-10-01 03:42:44 UTC
This test is expected to skip on any connector with a fixed mode. 
Since the test here is run on eDP config, this skip is expected.

Duplicate of this old bug. https://bugs.freedesktop.org/show_bug.cgi?id=109310
Comment 7 Jani Saarinen 2019-10-01 04:51:26 UTC
Lakshmi, let's resolve this based on this.
Comment 8 Lakshmi 2019-10-01 06:10:08 UTC
This is an expected skip, marked this bug as expected.
Comment 9 Ville Syrjala 2019-10-01 12:24:56 UTC
Ideally the test should force a VGA/HDMI connector on if none of the connected connectors are suitable.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.