Bug 110606 - [lib32] [vulkan-overlay-layer] build failure
Summary: [lib32] [vulkan-overlay-layer] build failure
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/Common (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
: 110607 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-05-04 15:10 UTC by LoneVVolf
Modified: 2019-05-07 10:10 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
build log (73.50 KB, text/x-log)
2019-05-04 15:10 UTC, LoneVVolf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description LoneVVolf 2019-05-04 15:10:15 UTC
Created attachment 144162 [details]
build log

When building multilib mesa trunk with 
-D vulkan-overlay-layer=true
build fails.
When building x86_64 everything works.
build log attached
Comment 1 Eric Engestrom 2019-05-07 10:09:05 UTC
*** Bug 110607 has been marked as a duplicate of this bug. ***
Comment 2 Eric Engestrom 2019-05-07 10:10:26 UTC
Fixed by:

commit 2d2927938f074f402cab28aa5322567a76cbde58
Author: Lionel Landwerlin <lionel.g.landwerlin@intel.com>
Date:   Fri May 3 16:42:55 2019 +0100

    vulkan/overlay-layer: fix cast errors
    
    Not quite sure what version of GCC/Clang produces errors (8.3.0
    locally was fine).
    
    v2: also fix an integer literal issue (Karol)
    
    Signed-off-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com>
    Reviewed-by: Tapani Pälli <tapani.palli@intel.com> (v1)
    Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.