Bug 110689 - [CI][DRMTIP] igt@kms_* - dmesg-warn - WARN_ON(intel_wait_for_register(&dev_priv->uncore, regs->driver, (0x1 << ((pw_idx) * 2)), (0x1 << ((pw_idx) * 2)), 1))
Summary: [CI][DRMTIP] igt@kms_* - dmesg-warn - WARN_ON(intel_wait_for_register(&dev_pr...
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Imre Deak
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-16 12:34 UTC by Martin Peres
Modified: 2019-08-09 13:16 UTC (History)
2 users (show)

See Also:
i915 platform: ICL
i915 features: CI Infra


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-05-16 12:34:57 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_286/fi-icl-dsi/igt@kms_3d.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_286/fi-icl-dsi/igt@kms_hdmi_inject@inject-audio.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_286/fi-icl-dsi/igt@kms_hdmi_inject@inject-4k.html

<4> [294.960828] WARN_ON(intel_wait_for_register(&dev_priv->uncore, regs->driver, (0x1 << ((pw_idx) * 2)), (0x1 << ((pw_idx) * 2)), 1))
<4> [294.960868] WARNING: CPU: 0 PID: 2423 at drivers/gpu/drm/i915/intel_runtime_pm.c:661 hsw_wait_for_power_well_enable.isra.9+0x4a/0x50 [i915]
<4> [294.961004]  intel_power_well_enable+0x35/0x40 [i915]
<4> [294.961029]  __intel_display_power_get_domain.part.17+0x69/0x80 [i915]
<4> [294.961056]  intel_display_power_get+0x44/0x60 [i915]
<4> [294.961093]  intel_ddi_pre_enable+0x763/0xb70 [i915]
<4> [294.961130]  intel_encoders_pre_enable.isra.20+0x61/0x80 [i915]
<4> [294.961202]  intel_update_crtc+0x51/0x3c0 [i915]
<4> [294.961272]  intel_atomic_commit_tail+0x205/0x1340 [i915]
<4> [294.961311]  intel_atomic_commit+0x240/0x2e0 [i915]
<4> [294.961318]  drm_atomic_helper_set_config+0x7b/0x90
<4> [294.961323]  drm_mode_setcrtc+0x199/0x710
<4> [294.961338]  ? drm_mode_getcrtc+0x180/0x180
<4> [294.961341]  drm_ioctl_kernel+0x83/0xf0
<4> [294.961345]  drm_ioctl+0x2f3/0x3b0
<4> [294.961349]  ? drm_mode_getcrtc+0x180/0x180
<4> [294.961450] WARNING: CPU: 0 PID: 2423 at drivers/gpu/drm/i915/intel_runtime_pm.c:661 hsw_wait_for_power_well_enable.isra.9+0x4a/0x50 [i915]
<4> [294.961487] Missing case (intel_dig_port->tc_type == 0)
<4> [294.961538] WARNING: CPU: 0 PID: 2423 at drivers/gpu/drm/i915/intel_ddi.c:3029 icl_program_mg_dp_mode+0xf6/0x1b0 [i915]
<4> [294.961705]  intel_ddi_pre_enable+0x76b/0xb70 [i915]
<4> [294.961749]  intel_encoders_pre_enable.isra.20+0x61/0x80 [i915]
<4> [294.961838]  intel_update_crtc+0x51/0x3c0 [i915]
<4> [294.961942]  intel_atomic_commit_tail+0x205/0x1340 [i915]
<4> [294.962000]  intel_atomic_commit+0x240/0x2e0 [i915]
<4> [294.962009]  drm_atomic_helper_set_config+0x7b/0x90
<4> [294.962015]  drm_mode_setcrtc+0x199/0x710
<4> [294.962037]  ? drm_mode_getcrtc+0x180/0x180
<4> [294.962041]  drm_ioctl_kernel+0x83/0xf0
<4> [294.962048]  drm_ioctl+0x2f3/0x3b0
<4> [294.962054]  ? drm_mode_getcrtc+0x180/0x180
<4> [294.962200] WARNING: CPU: 0 PID: 2423 at drivers/gpu/drm/i915/intel_ddi.c:3029 icl_program_mg_dp_mode+0xf6/0x1b0 [i915]
<3> [305.097515] [drm:drm_atomic_helper_wait_for_flip_done] *ERROR* [CRTC:82:pipe A] flip_done timed out
<3> [315.337515] [drm:drm_atomic_helper_wait_for_dependencies] *ERROR* [CRTC:82:pipe A] flip_done timed out
<3> [325.577509] [drm:drm_atomic_helper_wait_for_dependencies] *ERROR* [PLANE:30:plane 1A] flip_done timed out
<3> [335.817506] [drm:drm_atomic_helper_wait_for_flip_done] *ERROR* [CRTC:82:pipe A] flip_done timed out
<3> [346.057542] [drm:drm_atomic_helper_wait_for_dependencies] *ERROR* [CRTC:82:pipe A] flip_done timed out
<3> [356.297510] [drm:drm_atomic_helper_wait_for_dependencies] *ERROR* [CONNECTOR:190:HDMI-A-1] flip_done timed out
<3> [366.537510] [drm:drm_atomic_helper_wait_for_dependencies] *ERROR* [CONNECTOR:208:DSI-1] flip_done timed out
<3> [376.777524] [drm:drm_atomic_helper_wait_for_dependencies] *ERROR* [PLANE:30:plane 1A] flip_done timed out
<4> [376.886045] WARNING: CPU: 1 PID: 2423 at drivers/gpu/drm/i915/intel_display.c:1081 intel_disable_pipe+0x1c3/0x270 [i915]
<4> [376.886152] RIP: 0010:intel_disable_pipe+0x1c3/0x270 [i915]
<4> [376.886336]  intel_atomic_commit_tail+0x932/0x1340 [i915]
<4> [376.886422]  intel_atomic_commit+0x240/0x2e0 [i915]
<4> [376.886457]  drm_fb_helper_restore_fbdev_mode_unlocked+0x42/0x90
<4> [376.886464]  drm_fb_helper_set_par+0x24/0x50
<4> [376.886531]  intel_fbdev_set_par+0x11/0x40 [i915]
<4> [376.886737] WARNING: CPU: 1 PID: 2423 at drivers/gpu/drm/i915/intel_display.c:1081 intel_disable_pipe+0x1c3/0x270 [i915]
Comment 1 Martin Peres 2019-05-16 12:51:41 UTC
Setting the priority to high and assigning to Imre because this failure means that a power well we are trying to enable never gets enabled, which could have a disastrous customer impact.
Comment 2 CI Bug Log 2019-05-16 12:52:36 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* fi-icl-dsi: all tests - dmesg-warn - WARN_ON(intel_wait_for_register(&amp;dev_priv-&gt;uncore, regs-&gt;driver, (0x1 &lt;&lt; ((pw_idx) * 2)), (0x1 &lt;&lt; ((pw_idx) * 2)), 1))
  (No new failures associated)
Comment 3 Imre Deak 2019-05-16 15:41:05 UTC
There is an HDMI monitor plugged into the port C connector, but icl-dsi doesn't support this:

<7>[   11.547665] [drm:intel_bios_init [i915]] Port C VBT info: DP:0 HDMI:1 DVI:1 EDP:0 CRT:0 TCUSB:1 TBT:1

(meaning port C is not configured for legacy TypeC mode as it should be for HDMI, rather in DP/TBT-alt TypeC mode).

If the RVP has the F08 rework for HDMI, then the proper BIOS needs to be flashed on it and the corresponding BIOS setup (advanced/system agent/display/portX) applied.

If the rework is not done on the RVP (and/or we don't want to test HDMI on this machine) then we have to make sure not to connect any HDMI monitor to it.

It's also strange why the HDMI monitor appears only in the middle of the test run (and is not connected during booting), but I think it's not worth investigating that, before fixing the machine configuration.
Comment 4 Jani Saarinen 2019-05-24 08:43:57 UTC
Hi,
There is only DSI panel on this. No HDMI plugged in.
Comment 5 Jani Saarinen 2019-05-24 09:48:40 UTC
Isnt this similar like 108070?
Comment 6 Jani Saarinen 2019-05-24 12:19:54 UTC
This cannot be high as no real customer impact. They have proper VBT anyway.
Comment 7 Lakshmi 2019-05-31 13:36:59 UTC
The reproduction rate of this failure is 100% on icl-dsi machine.
Comment 8 Imre Deak 2019-05-31 15:04:02 UTC
(In reply to Lakshmi from comment #7)
> The reproduction rate of this failure is 100% on icl-dsi machine.

We have still a wrong VBT as described in comment#3. I haven't seen any follow-up on fixing this VBT issue yet, driving that effort (fixing the VBT for this machine) would be the next step, by the person who can provide a new fixed VBT.
Comment 9 Imre Deak 2019-08-09 13:16:48 UTC
The VBT has been changed now and has:

<7>[    9.660348] [drm:intel_bios_init [i915]] Port C VBT info: CRT:0 DVI:0 HDMI:0 DP:1 eDP:0 LSPCON:0 USB-Type-C:0 TBT:0

so the port is marked as connected to a native Display Port connector. However due to the missing RVP rework or the wrong setting in BIOS setup, the corresponding PHY is still not ready for legacy mode:

<7>[    9.677087] [drm:icl_tc_phy_connect [i915]] Port C/TC#1: PHY not ready
<7>[    9.677147] [drm:intel_tc_port_sanitize [i915]] Port C/TC#1: sanitize mode (tbt-alt)

However we can close this bug as the originally reported timeouts shouldn't happen, as the driver will not use the port in legacy/DP-alt mode (which originally caused the timeouts).


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.