Bug 110695 - [hsw] GPU HANG: ecode 7:0:0x85dffffc, in kwin_x11
Summary: [hsw] GPU HANG: ecode 7:0:0x85dffffc, in kwin_x11
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 19.0
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-16 16:46 UTC by omega
Modified: 2019-06-14 08:12 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
cat /sys/class/drm/card0/error (44.87 KB, text/plain)
2019-05-16 16:46 UTC, omega
Details
/var/log/Xorg.0.log (41.76 KB, text/x-log)
2019-05-26 18:35 UTC, omega
Details

Note You need to log in before you can comment on or make changes to this bug.
Description omega 2019-05-16 16:46:16 UTC
Created attachment 144283 [details]
cat /sys/class/drm/card0/error

Frequent crashes of windows manager, kernel log:


[ 2323.922388] [drm] GPU HANG: ecode 7:0:0x85dffffc, in kwin_x11 [2635], reason: hang on rcs0, action: reset
[ 2323.922390] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 2323.922390] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[ 2323.922390] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 2323.922391] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[ 2323.922391] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[ 2323.922425] i915 0000:00:02.0: Resetting chip for hang on rcs0



Linux sauron 5.0.13-050013-generic #201905051330 SMP Sun May 5 13:32:41 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux


model name      : Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz
Comment 1 Paul 2019-05-17 08:45:09 UTC
Hello Omega
Thanks for the report.
Will be helpful if you provide information about your distro, version of mesa and it's setup configuration for the issue reproducing?
Comment 2 omega 2019-05-26 18:34:21 UTC
Please pardon the delay, I have just returned from traveling abroad for 10 days.

Distro: KUbuntu 19.04 running KDE
Mesa: 19.0.2
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.0.13-050013-generic root=UUID=472e2837-f230-4f53-8eaf-d1e06c00da48 ro quiet splash i915.enable_rc6=0 vt.handoff=1

Adding /var/log/Xorg.0.log as attachment.

Please let me know if and how I should gather additional information.
Comment 3 omega 2019-05-26 18:35:00 UTC
Created attachment 144348 [details]
/var/log/Xorg.0.log
Comment 4 Paul 2019-05-28 14:29:16 UTC
Hello
I've tried to reproduce the issue on my HSW (Intel® HD Graphics 4600 ) with mesa 19.0.2, 5.0.13 version of Kernel - but with no luck, unfortunately.
Maybe, you are doing some specific actions or anything else?
Please, tell about steps which cause the gpu hang.
Thanks
Comment 5 omega 2019-05-28 15:58:10 UTC
Hi Paul,

unfortunately I cannot identify a particular action that causes the GPU hang.

Yesterday, I worked two hours without issues, today, it occured after 15 minutes.

I'd like to hypothesize that it is related to VirtualBox running a local virtual machine with local display of the virtual machine, or running a video (Youtube). 

The virtual machine has 3D acceleration and 2D video acceleration enabled but no 3D application nor video ran in it at the time of the hang.

I will start to test the hypothesis and check if and only if the hang occurs only with virtual machine displayed or video shown.

Best regards,
Boris
Comment 6 omega 2019-05-29 17:58:34 UTC
The GPU hang also occurs after a fresh restart of the system with neither VirtualBox nor a video nor any other graphical application running, just while writing an innocent e-mail, right out of the blue. There is nothing before or after the crash report in the syslog, just this:

[ 3455.022475] [drm] GPU HANG: ecode 7:0:0x85dffffc, in kwin_x11 [1583], reason: hang on rcs0, action: reset
[ 3455.022476] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 3455.022476] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[ 3455.022477] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 3455.022477] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[ 3455.022478] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[ 3455.022519] i915 0000:00:02.0: Resetting chip for hang on rcs0
Comment 7 omega 2019-06-06 18:00:09 UTC
I found and eliminated the reason for the GPU hang. I reviewed the BIOS settings of the computer and saw that turbo performance was activated (overclocking). I returned the settings to be in the thresholds for normal operations. This was one week ago and I experienced no more GPU hangs since then. Suppose that the reason for the GPU hang was running the clocks with insane values.
Comment 8 Denis 2019-06-14 08:12:11 UTC
then closing this ticket. Please fill free to reopen if issue returned


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.