Bug 110736 - Spotify rendering issues
Summary: Spotify rendering issues
Status: RESOLVED DUPLICATE of bug 110721
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-23 12:19 UTC by Jan Ziak (http://atom-symbol.net)
Modified: 2019-05-23 19:04 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Screenshot_20190523_135549.png (343.27 KB, image/png)
2019-05-23 12:19 UTC, Jan Ziak (http://atom-symbol.net)
Details
Brave browser (503.50 KB, image/png)
2019-05-23 18:30 UTC, Mathieu Belanger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Ziak (http://atom-symbol.net) 2019-05-23 12:19:12 UTC
Created attachment 144330 [details]
Screenshot_20190523_135549.png

Hello.

I am experiencing Spotify rendering issues with Mesa 19.0.5, 19.1.0-rc3 and git. Mesa 18.3.6 has no rendering issues.

Please see the attached screenshot.

This issue might be triggered by a special combination of Mesa and other graphics libraries, because there exist points in time where there were no rendering issues when using Mesa versions 19.1.0-rc3 and git.

Passing --disable-gpu to Spotify removes the rendering issues.

Spotify 1.1.5 download location: http://repository-origin.spotify.com/pool/non-free/s/spotify-client/

$ glversion 
4.5 (Core Profile) Mesa 19.1.0-rc3
AMD Radeon (TM) RX 470/570 Graphics (POLARIS10, DRM 3.30.0, 5.1.0, LLVM 8.0.0)
Comment 1 Mathieu Belanger 2019-05-23 18:29:58 UTC
I have the same bug

It started yesterday after a reboot.

Between the reboot and the previous reboot I did emerge -e the whole things so I'm not totally sure it's mesa related

I have the bug in:
 * Discord (only the rotating Discord logo when I load it, it spin like 30x on itself in the same amount of time it usually spin one time on itself.)
 * Brave browser (corruptopia like OP screen shot)
 * Chromium (partially, just the scroll bar)

@Zak, is there is something else you also updated recently? Like libdrm, xorg parts, llvm?
Comment 2 Mathieu Belanger 2019-05-23 18:30:57 UTC
Created attachment 144332 [details]
Brave browser

Here a screenshot of a Brave browser tab
Comment 3 Mathieu Belanger 2019-05-23 18:32:30 UTC
I would also add that the previous git version I did compile did not have the problem (Fri May 10 17:39:53 2019)
Comment 4 Mathieu Belanger 2019-05-23 19:04:33 UTC

*** This bug has been marked as a duplicate of bug 110721 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.