Bug 110755 - [CI][BAT] igt@i915_module_load@reload - dmesg-warn - WARN_ON(!guc_verify_doorbells(guc))
Summary: [CI][BAT] igt@i915_module_load@reload - dmesg-warn - WARN_ON(!guc_verify_door...
Status: RESOLVED WONTFIX
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: highest normal
Assignee: Michal Wajdeczko
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-24 09:46 UTC by Martin Peres
Modified: 2019-08-21 12:42 UTC (History)
1 user (show)

See Also:
i915 platform: BXT
i915 features: firmware/guc


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-05-24 09:46:51 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6136/fi-apl-guc/igt@i915_module_load@reload.html

<7> [294.418894] [drm:intel_atomic_commit_tail [i915]] [CRTC:55:pipe A]
<7> [294.469846] [drm:doorbell_ok [i915]] Doorbell 0 has unexpected state: valid=yes
<7> [294.470253] [drm:doorbell_ok [i915]] Doorbell 128 has unexpected state: valid=yes
<4> [294.470575] ------------[ cut here ]------------
<4> [294.470579] WARN_ON(!guc_verify_doorbells(guc))
<4> [294.470710] WARNING: CPU: 2 PID: 2987 at drivers/gpu/drm/i915/intel_guc_submission.c:1289 intel_guc_submission_fini+0xc2/0xd0 [i915]
<4> [294.470714] Modules linked in: vgem mei_hdcp snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic x86_pkg_temp_thermal coretemp crct10dif_pclmul crc32_pclmul btusb btrtl btbcm btintel bluetooth ghash_clmulni_intel ecdh_generic ecc lpc_ich r8169 i915(-) realtek snd_hda_codec snd_hwdep snd_hda_core mei_me mei snd_pcm pinctrl_broxton pinctrl_intel prime_numbers [last unloaded: snd_hda_intel]
<4> [294.470749] CPU: 2 PID: 2987 Comm: i915_module_loa Tainted: G     U            5.2.0-rc1-CI-CI_DRM_6136+ #1
<4> [294.470752] Hardware name: Intel corporation NUC6CAYS/NUC6CAYB, BIOS AYAPLCEL.86A.0056.2018.0926.1100 09/26/2018
<4> [294.470834] RIP: 0010:intel_guc_submission_fini+0xc2/0xd0 [i915]
<4> [294.470841] Code: be 01 00 00 00 5b 5d 41 5c 41 5d e9 08 2f ff ff 5b 5d 41 5c 41 5d c3 48 c7 c6 70 25 29 a0 48 c7 c7 aa 65 2b a0 e8 ee d5 f0 e0 <0f> 0b eb b2 66 2e 0f 1f 84 00 00 00 00 00 41 57 41 56 41 55 41 54
<4> [294.470845] RSP: 0018:ffffc90000c6bdb8 EFLAGS: 00010286
<4> [294.470849] RAX: 0000000000000000 RBX: 0000000000000100 RCX: 0000000000000002
<4> [294.470853] RDX: 0000000000001671 RSI: ffff8882466708e0 RDI: ffffffff8212d479
<4> [294.470856] RBP: 0000000000000000 R08: 00000000eb47685f R09: 0000000000000000
<4> [294.470860] R10: 0000000000000000 R11: 0000000000000000 R12: ffff88825fa511f0
<4> [294.470863] R13: 0000000000000000 R14: 0000000000000000 R15: ffffffffa03352d0
<4> [294.470867] FS:  00007f0528e4ee40(0000) GS:ffff888277b00000(0000) knlGS:0000000000000000
<4> [294.470871] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
<4> [294.470874] CR2: 0000559e6e8d22e8 CR3: 0000000274baa000 CR4: 00000000003406e0
<4> [294.470878] Call Trace:
<4> [294.470964]  intel_uc_fini+0x46/0x140 [i915]
<4> [294.471039]  i915_gem_fini+0x70/0x1a0 [i915]
<4> [294.471105]  i915_driver_unload+0xdd/0x130 [i915]
<4> [294.471169]  i915_pci_remove+0x19/0x30 [i915]
<4> [294.471178]  pci_device_remove+0x36/0xb0
<4> [294.471186]  device_release_driver_internal+0xd3/0x1b0
<4> [294.471193]  driver_detach+0x3f/0x80
<4> [294.471199]  bus_remove_driver+0x53/0xd0
<4> [294.471205]  pci_unregister_driver+0x25/0xa0
<4> [294.471291]  i915_exit+0x16/0x1c [i915]
<4> [294.471297]  __se_sys_delete_module+0x162/0x210
<4> [294.471304]  ? trace_hardirqs_off_thunk+0x1a/0x1c
<4> [294.471310]  ? do_syscall_64+0xd/0x1c0
<4> [294.471316]  do_syscall_64+0x55/0x1c0
<4> [294.471323]  entry_SYSCALL_64_after_hwframe+0x49/0xbe
<4> [294.471327] RIP: 0033:0x7f05284f51b7
<4> [294.471332] Code: 73 01 c3 48 8b 0d d1 8c 2c 00 f7 d8 64 89 01 48 83 c8 ff c3 66 2e 0f 1f 84 00 00 00 00 00 0f 1f 44 00 00 b8 b0 00 00 00 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d a1 8c 2c 00 f7 d8 64 89 01 48
<4> [294.471335] RSP: 002b:00007ffc364eb748 EFLAGS: 00000206 ORIG_RAX: 00000000000000b0
<4> [294.471340] RAX: ffffffffffffffda RBX: 0000000000000000 RCX: 00007f05284f51b7
<4> [294.471343] RDX: 0000000000000001 RSI: 0000000000000800 RDI: 00005621fd34fd78
<4> [294.471346] RBP: 00005621fd34fd10 R08: 00005621fd34fd7c R09: 00007ffc364eb770
<4> [294.471350] R10: 00007ffc364ea744 R11: 0000000000000206 R12: 0000000000000000
<4> [294.471353] R13: 00007ffc364eb8f0 R14: 0000000000000000 R15: 0000000000000000
<4> [294.471370] irq event stamp: 135798
<4> [294.471376] hardirqs last  enabled at (135797): [<ffffffff811283ec>] vprintk_emit+0xcc/0x340
<4> [294.471380] hardirqs last disabled at (135798): [<ffffffff810019e0>] trace_hardirqs_off_thunk+0x1a/0x1c
<4> [294.471385] softirqs last  enabled at (135144): [<ffffffff81c0033a>] __do_softirq+0x33a/0x4b9
<4> [294.471391] softirqs last disabled at (135119): [<ffffffff810b6319>] irq_exit+0xa9/0xc0
<4> [294.471470] WARNING: CPU: 2 PID: 2987 at drivers/gpu/drm/i915/intel_guc_submission.c:1289 intel_guc_submission_fini+0xc2/0xd0 [i915]
<4> [294.471473] ---[ end trace 14097301b239b394 ]---
Comment 1 CI Bug Log 2019-05-24 09:51:54 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* GUC: igt@i915_module_load@reload - dmesg-warn - WARN_ON(!guc_verify_doorbells(guc))
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_4259/fi-apl-guc/igt@i915_module_load@reload.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_13075/fi-apl-guc/igt@i915_module_load@reload.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_13082/fi-apl-guc/igt@i915_module_load@reload.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6136/fi-apl-guc/igt@i915_module_load@reload.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6137/fi-apl-guc/igt@i915_module_load@reload.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_3048/fi-apl-guc/igt@i915_module_load@reload.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_3049/fi-apl-guc/igt@i915_module_load@reload.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_4337/fi-apl-guc/igt@i915_module_load@reload.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_13085/fi-apl-guc/igt@i915_module_load@reload.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5012/fi-apl-guc/igt@i915_module_load@reload.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_3050/fi-apl-guc/igt@i915_module_load@reload.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_3051/fi-apl-guc/igt@i915_module_load@reload.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_13087/fi-apl-guc/igt@i915_module_load@reload.html

* GUC: igt@runner@aborted - fail - Previous test: i915_module_load (reload)
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_4259/fi-apl-guc/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_13075/fi-apl-guc/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_13082/fi-apl-guc/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6136/fi-apl-guc/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6137/fi-apl-guc/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_3048/fi-apl-guc/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_3049/fi-apl-guc/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_4337/fi-apl-guc/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_13085/fi-apl-guc/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5012/fi-apl-guc/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_3050/fi-apl-guc/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_3051/fi-apl-guc/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_13087/fi-apl-guc/igt@runner@aborted.html
Comment 2 Chris Wilson 2019-05-28 11:15:55 UTC
commit a2904ade3dc28cf1a1b7deded41f4369f75e664c
Author: Michal Wajdeczko <michal.wajdeczko@intel.com>
Date:   Mon May 27 18:35:58 2019 +0000

    drm/i915/guc: Don't allow GuC submission
    
    Due to the upcoming changes to the GuC ABI interface, we must
    disable GuC submission mode until final ABI will be available
    on all GuC firmwares.
    
    To avoid regressions on systems configured to run with no longer
    supported configuration "enable_guc=3" or "enable_guc=1" clear
    GuC submission bit.
    
    v2: force switch to non-GuC submission mode
    v3: use GEM_BUG_ON (Joonas)
    
    Signed-off-by: Michal Wajdeczko <michal.wajdeczko@intel.com>
    Cc: Joonas Lahtinen <joonas.lahtinen@linux.intel.com>
    Cc: Chris Wilson <chris@chris-wilson.co.uk>
    Cc: Rodrigo Vivi <rodrigo.vivi@intel.com>
    Cc: Daniele Ceraolo Spurio <daniele.ceraolospurio@intel.com>
    Cc: John Spotswood <john.a.spotswood@intel.com>
    Cc: Vinay Belgaumkar <vinay.belgaumkar@intel.com>
    Cc: Tony Ye <tony.ye@intel.com>
    Cc: Anusha Srivatsa <anusha.srivatsa@intel.com>
    Cc: Jeff Mcgee <jeff.mcgee@intel.com>
    Cc: Antonio Argenziano <antonio.argenziano@intel.com>
    Cc: Sujaritha Sundaresan <sujaritha.sundaresan@intel.com>
    Cc: Martin Peres <martin.peres@linux.intel.com>
    Acked-by: Martin Peres <martin.peres@linux.intel.com>
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
    Link: https://patchwork.freedesktop.org/patch/msgid/20190527183613.17076-3-michal.wajdeczko@intel.com
Comment 3 CI Bug Log 2019-08-21 12:42:22 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.