Bug 110759 - Blender 2.8 crash when selecting geometry with 19.0.5
Summary: Blender 2.8 crash when selecting geometry with 19.0.5
Status: RESOLVED DUPLICATE of bug 110721
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: 19.0
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-25 07:16 UTC by Doug Ty
Modified: 2019-05-25 09:17 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Doug Ty 2019-05-25 07:16:21 UTC
I've recently updated to mesa 19.0.5 on Arch Linux, and it's consistently crashing Blender for me -- reverting to 19.0.4, everything is fine again.

Using the development build of Blender 2.8 (tested with 2019-05-24 caf52e3779a9), mesa 19.0.5 crashes upon selecting any geometry inside Blender. This renders Blender quite unusable, so unfortunately this is a pretty show stopping issue for me.

To reproduce:
1. Open Blender and select the default cube
2. Press tab to enter edit mode
3. Click on a vertex (and crash)

OS: Arch Linux x64
Kernel: Linux 5.1.4
Mesa: 19.0.5
LLVM: 8.0.0
CPU: Ryzen 2700X
GPU: Vega 56

Please let me know if further information is required. I am unsure of how to generate a meaningful log from Blender.
Comment 1 Doug Ty 2019-05-25 07:52:42 UTC
Update:

This also happens with the latest development build of mesa (19.2.0_devel.111215.1dc593e9b93 as compiled via mesa-git package on AUR)


I believe this is related to Bug 110721:
https://bugs.freedesktop.org/show_bug.cgi?id=110721

...As reverting "mesa: unreference current winsys buffers when unbinding winsys buffers" fixes the crashing in Blender (in addition to the issues presented in the other bug report.)

Using master + reverting that commit seems to resolve the issue for me.
Comment 2 Doug Ty 2019-05-25 09:17:26 UTC

*** This bug has been marked as a duplicate of bug 110721 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.