Bug 110776 - [CI][DRMTIP] igt@gem_create@create-clear - dmesg-warn - rcu_preempt detected stalls on CPUs/tasks
Summary: [CI][DRMTIP] igt@gem_create@create-clear - dmesg-warn - rcu_preempt detected ...
Status: RESOLVED DUPLICATE of bug 110789
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-27 15:41 UTC by Lakshmi
Modified: 2019-05-29 21:32 UTC (History)
1 user (show)

See Also:
i915 platform: PNV
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-05-27 15:41:15 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_294/fi-pnv-d510/igt@gem_create@create-clear.html
<6> [421.425230] Console: switching to colour dummy device 80x25
<6> [421.425754] [IGT] gem_create: executing
<6> [421.452614] [IGT] gem_create: starting subtest create-clear
<6> [457.714835] [IGT] gem_create: exiting, ret=0
<5> [457.728596] Setting dangerous option reset - tainting kernel
<3> [483.636080] rcu: INFO: rcu_preempt detected stalls on CPUs/tasks:
<3> [483.636082] rcu: 	Tasks blocked on level-0 rcu_node (CPUs 0-3): P851
<4> [483.636082] 	(detected by 3, t=65002 jiffies, g=225453, q=48621)
<6> [483.636082] java            R  running task    13832   851    812 0x00004000
<4> [483.636082] Call Trace:
<4> [483.636082]  ? mark_held_locks+0x49/0x70
<4> [483.636082]  ? trace_hardirqs_on_thunk+0x1a/0x1c
<4> [483.636082]  ? lockdep_hardirqs_on+0xe3/0x1b0
<4> [483.636082]  ? trace_hardirqs_on_thunk+0x1a/0x1c
<4> [483.636082]  ? retint_kernel+0x2b/0x2b
<4> [483.636082]  ? lock_is_held_type+0xfb/0x120
<4> [483.636082]  ? lock_is_held_type+0x8/0x120
<4> [483.636082]  ? xas_load+0xa/0x50
<4> [483.636082]  ? find_get_entry+0xa2/0x300
<4> [483.636082]  ? pagecache_get_page+0x2b/0x220
<4> [483.636082]  ? lookup_swap_cache+0x3b/0x100
<4> [483.636082]  ? do_swap_page+0x86/0x910
<4> [483.636082]  ? __handle_mm_fault+0x66a/0xfa0
<4> [483.636082]  ? handle_mm_fault+0x155/0x350
<4> [483.636082]  ? __do_page_fault+0x248/0x4f0
<4> [483.636082]  ? page_fault+0x8/0x30
<4> [483.636082]  ? page_fault+0x1e/0x30
<3> [554.628258] INFO: task gem_create:1101 blocked for more than 61 seconds.
<3> [554.628635]       Tainted: G     U  W         5.2.0-rc1-ga388075b2bdc-drmtip_294+ #1
<3> [554.628786] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
<6> [554.628937] gem_create      D13320  1101    999 0x00004000
<4> [554.628967] Call Trace:
<4> [554.629007]  ? __schedule+0x311/0x840
<4> [554.629044]  ? wait_for_common+0x116/0x1f0
<4> [554.629224]  schedule+0x2e/0xb0
<4> [554.629246]  schedule_timeout+0x21b/0x3d0
<4> [554.629268]  ? lock_acquire+0xa6/0x1c0
<4> [554.629296]  ? wait_for_common+0x116/0x1f0
<4> [554.629316]  ? mark_held_locks+0x49/0x70
<4> [554.629335]  ? _raw_spin_unlock_irq+0x24/0x50
<4> [554.629362]  ? wait_for_common+0x116/0x1f0
<4> [554.629380]  wait_for_common+0x13a/0x1f0
<4> [554.629405]  ? wake_up_q+0x80/0x80
<4> [554.629443]  rcu_barrier+0x11c/0x190
<4> [554.629683]  i915_drop_caches_set+0xb1/0x270 [i915]
<4> [554.629726]  simple_attr_write+0xb0/0xd0
<4> [554.629759]  full_proxy_write+0x51/0x80
<4> [554.629791]  vfs_write+0xbd/0x1b0
<4> [554.629820]  ksys_write+0x8f/0xe0
<4> [554.629854]  do_syscall_64+0x55/0x1c0
<4> [554.629877]  entry_SYSCALL_64_after_hwframe+0x49/0xbe
<4> [554.629894] RIP: 0033:0x7fda39e562b7
<4> [554.629917] Code: Bad RIP value.
<4> [554.629930] RSP: 002b:00007ffd8916df60 EFLAGS: 00000293 ORIG_RAX: 0000000000000001
<4> [554.629947] RAX: ffffffffffffffda RBX: 0000000000000008 RCX: 00007fda39e562b7
<4> [554.629960] RDX: 0000000000000005 RSI: 00007ffd8916dfe0 RDI: 0000000000000008
<4> [554.629972] RBP: 00007ffd8916dfe0 R08: 0000000000000000 R09: 0000000000000000
<4> [554.629985] R10: 0000000000000000 R11: 0000000000000293 R12: 0000000000000005
<4> [554.629998] R13: 0000000000000008 R14: 00007ffd8916dfe0 R15: 00007fda39e40d80
<4> [554.630161] 
Showing all locks held in the system:
<4> [554.630195] 1 lock held by khungtaskd/33:
<4> [554.630206]  #0: 0000000029a5d521 (rcu_read_lock){....}, at: debug_show_all_locks+0xe/0x1a0
<4> [554.630273] 1 lock held by in:imklog/326:
<4> [554.630298] 2 locks held by java/851:
<4> [554.630312] 2 locks held by java/852:
<4> [554.630333] 1 lock held by dmesg/982:
<4> [554.630349] 3 locks held by gem_create/1101:
<4> [554.630361]  #0: 00000000843912bb (sb_writers#14){.+.+}, at: vfs_write+0x18e/0x1b0
<4> [554.630394]  #1: 0000000044713cf1 (&attr->mutex){+.+.}, at: simple_attr_write+0x36/0xd0
<4> [554.630423]  #2: 00000000f8d8f89c (rcu_state.barrier_mutex){+.+.}, at: rcu_barrier+0x23/0x190
<4> [554.630455] 
<4> [554.630466] =============================================

<6> [601.299333] Console: switching to colour frame buffer device 128x48
Comment 1 CI Bug Log 2019-05-27 15:43:17 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* PNV: igt@gem_create@create-clear - dmesg-warn - rcu_preempt detected stalls on CPUs/tasks
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_294/fi-pnv-d510/igt@gem_create@create-clear.html

* PNV:  igt@runner@aborted - fail - Previous test: gem_create (create-clear)
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_294/fi-pnv-d510/igt@runner@aborted.html
Comment 2 Chris Wilson 2019-05-29 21:32:04 UTC

*** This bug has been marked as a duplicate of bug 110789 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.