Bug 110787 - Glitches in console of the Julia language plugin for Atom (Juno)
Summary: Glitches in console of the Julia language plugin for Atom (Juno)
Status: RESOLVED DUPLICATE of bug 110721
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: 19.0
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-28 22:24 UTC by Manuel Vögele
Modified: 2019-05-29 13:35 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
A screenshot showing the graphical artifacts in the console (210.80 KB, image/png)
2019-05-28 22:24 UTC, Manuel Vögele
Details
Output of glxinfo (144.81 KB, text/plain)
2019-05-28 22:25 UTC, Manuel Vögele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Vögele 2019-05-28 22:24:29 UTC
Created attachment 144366 [details]
A screenshot showing the graphical artifacts in the console

Since Mesa 19.0.5 the REPL-Console in the Julia language plugin is unusable and often shows artifacts. Mesa 19.0.4 seems not to be affectd by this.

Steps to reproduce:
1. Install the Atom and the Julia language plugin (Juno) according to this gude: http://docs.junolab.org/latest/man/installation/
During the installation agree to open julia specific views by default.
2. Open up atom. A console windows should appear on the bottom.
3. Click around (switching between clicks in the console, in the editor and in windows that don't belong to atom). This usually causes graphical glitches to appear in the Julia console (REPL). If this doesn't happen try using the console - I am usually unable to use it since even if it doesn't get filled with artifacts it still won't render properly which makes it unusable.

I've attached a screenshot of the broken console.

I'm using Arch Linux with KDE Plasma as desktop environment.

Unfortunately I'm unable to provide an apitrace since runnign atom with apitrace caused the bug to disappear.
Comment 1 Manuel Vögele 2019-05-28 22:25:17 UTC
Created attachment 144367 [details]
Output of glxinfo
Comment 2 Pierre-Eric Pelloux-Prayer 2019-05-29 07:55:06 UTC
Thanks for your bug report.

It seems to be the same bug than https://bugs.freedesktop.org/show_bug.cgi?id=110721 

Should be fixed on master - can you try it?
Comment 3 Manuel Vögele 2019-05-29 10:22:31 UTC
Can confirm this is fixed on master.
Comment 4 Alex Deucher 2019-05-29 13:35:23 UTC

*** This bug has been marked as a duplicate of bug 110721 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.