Bug 110800 - [ivb] GPU hang: Desktop Graphics Intermittently Restarts while logged into plasma5 DRI/DRM
Summary: [ivb] GPU hang: Desktop Graphics Intermittently Restarts while logged into pl...
Status: RESOLVED DUPLICATE of bug 111014
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard: Triaged
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-31 01:09 UTC by jshand2013
Modified: 2019-07-02 19:26 UTC (History)
3 users (show)

See Also:
i915 platform: IVB
i915 features:


Attachments
inxi debug priority 20 (553.49 KB, application/gzip)
2019-05-31 01:09 UTC, jshand2013
Details
journalctl priority 7 (226.93 KB, text/plain)
2019-05-31 01:10 UTC, jshand2013
Details
kwinrc (456 bytes, text/plain)
2019-06-06 11:03 UTC, jshand2013
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jshand2013 2019-05-31 01:09:31 UTC
Created attachment 144390 [details]
inxi debug priority 20

Ever since kernel 5.1.2, i have noticed that the plasma5 desktop restarts (not wayland).

This usually happens while logged in to a desktop session.

When it restarts i haven't worked out, as it seems to happen at will

i forgot to mention, that when the restart happens, you remain in the logged in session
Comment 1 jshand2013 2019-05-31 01:10:35 UTC
Created attachment 144391 [details]
journalctl priority 7
Comment 2 Felix Miata 2019-05-31 07:06:19 UTC
adding downstream bug:
https://bugzilla.opensuse.org/show_bug.cgi?id=1136837

Ivybridge Mobil PCI ID 8086:0166 is in the attachment collection.
Comment 3 Lakshmi 2019-05-31 07:15:59 UTC
Can you attach dmesg from boot with kernel parameters drm.debug=0x1e log_buf_len=4M.

It is highly recommended to verify the issue with drmtip.
(https://cgit.freedesktop.org/drm-tip)
Comment 4 Denis 2019-06-06 10:40:15 UTC
hi. Could you please add here information from the file:
>~/.config/kwinrc
Just want to double check that we didn't lose anything during trying to reproduce this issue.
Comment 5 jshand2013 2019-06-06 11:01:55 UTC
(In reply to Denis from comment #4)
> hi. Could you please add here information from the file:
> >~/.config/kwinrc
> Just want to double check that we didn't lose anything during trying to
> reproduce this issue.

i have added the file you need
Comment 6 jshand2013 2019-06-06 11:03:44 UTC
Created attachment 144468 [details]
kwinrc
Comment 7 Jiri Slaby 2019-06-20 11:10:07 UTC
FTR, the downstream bug:
https://bugzilla.suse.com/show_bug.cgi?id=1136837

(In reply to Lakshmi from comment #3)
> It is highly recommended to verify the issue with drmtip.
> (https://cgit.freedesktop.org/drm-tip)

I am not sure he is able to compile kernels. In anyway, you could try at least linux-next from:
https://download.opensuse.org/repositories/Kernel:/linux-next/standard/

Note that the build is broken at the moment and we are working on a fix. A fresh one should appear tomorrow or so.
Comment 8 Chris Wilson 2019-07-02 19:26:01 UTC
Please test with

commit c84c9029d782a3a0d2a7f0522ecb907314d43e2c
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Fri Apr 19 12:17:47 2019 +0100

    drm/i915/ringbuffer: EMIT_INVALIDATE *before* switch context

heading to v5.1 via stable in the next few weeks.

*** This bug has been marked as a duplicate of bug 111014 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.