Bug 110808 - display stops updating after VT switch
Summary: display stops updating after VT switch
Status: RESOLVED NOTOURBUG
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/AMDgpu (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-01 17:50 UTC by Ross Vandegrift
Modified: 2019-06-04 07:47 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xserver log file (35.14 KB, text/plain)
2019-06-01 17:50 UTC, Ross Vandegrift
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ross Vandegrift 2019-06-01 17:50:14 UTC
Created attachment 144404 [details]
xserver log file

After starting Xorg with the AMDGPU driver, I switch to a different VT.
When I switch back to X, the display has frozen.  Only the mouse cursor
moves.  To reproduce:

1) From a linux console with no display manager or X session running:
    $ startx /usr/bin/xterm
2) Switch to a different VT and back.
3) Nothing appears in the xterm when typing.
4) Switch to a different VT and back, the old typing appears.

The screen isn't updating correctly but the client & server are
functioning.  I can run commands in the terminal, but can't see any
output without a VT switch.  Exiting the xterm immediately ends the X
session cleanly.

The same issue is triggered by a suspend/resume cycle.

This is using amdgpu 19.0.1 from Debian sid.  Same issue with the version in buster (18.1.99+git20190207-1)

Video device info:
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Stoney [Radeon R2/R3/R4/R5 Graphics] [1002:98e4] (rev eb)

Debian bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=929822

Ross
Comment 1 Michel Dänzer 2019-06-03 09:17:04 UTC
Does this not happen using the modesetting driver instead of xf86-video-amdgpu?

If not, how much time passes between VT switching away from Xorg and back to it?
Comment 2 Ross Vandegrift 2019-06-03 16:10:25 UTC
Same behavior with modesetting, so maybe this is a kernel/dri issue?  (Xorg uses amdgpu by default, so I stuck with that)  But wayland sessions do not trigger the bug.

No delay required after VT switch.  I originally found this due to the way gdm spawns another X server and immediately does chvt (so gdm X sessions always freeze on this system).
Comment 3 Michel Dänzer 2019-06-04 07:47:46 UTC
(In reply to Ross Vandegrift from comment #2)
> Same behavior with modesetting, so maybe this is a kernel/dri issue?

Or a general X server issue, so maybe file an issue at https://gitlab.freedesktop.org/xorg/xserver/issues/new .

Anyway, not a driver issue, resolving accordingly. Thanks for the report.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.