Bug 110826 - [CI][BAT] igt@i915_module_load@reload-with-fault-injection - incomplete - GEM_BUG_ON(i915_gem_object_has_pages(obj))
Summary: [CI][BAT] igt@i915_module_load@reload-with-fault-injection - incomplete - GEM...
Status: RESOLVED WONTFIX
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-03 11:57 UTC by Martin Peres
Modified: 2019-06-20 19:15 UTC (History)
1 user (show)

See Also:
i915 platform: ILK
i915 features: display/Other, GEM/Other, power/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-06-03 11:57:30 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5026/fi-ilk-m540/igt@i915_module_load@reload-with-fault-injection.html

<3> [292.945101] __i915_gem_free_objects:236 GEM_BUG_ON(i915_gem_object_has_pages(obj))
<4> [292.945225] ------------[ cut here ]------------
<2> [292.945229] kernel BUG at drivers/gpu/drm/i915/gem/i915_gem_object.c:236!
<4> [292.945278] invalid opcode: 0000 [#1] PREEMPT SMP PTI
<4> [292.945290] CPU: 2 PID: 2487 Comm: kworker/u16:32 Tainted: G     U            5.2.0-rc2-CI-CI_DRM_6169+ #1
<4> [292.945307] Hardware name: Hewlett-Packard HP EliteBook 8440p/172A, BIOS 68CCU Ver. F.24 09/13/2013
<4> [292.945423] Workqueue: i915 __i915_gem_free_work [i915]
<4> [292.945501] RIP: 0010:__i915_gem_free_objects+0x2be/0x730 [i915]
<4> [292.945514] Code: 21 b7 f6 e0 48 8b 35 49 af 1f 00 49 c7 c0 b0 39 2f a0 b9 ec 00 00 00 48 c7 c2 a0 d1 2c a0 48 c7 c7 b9 d4 1b a0 e8 82 7c fd e0 <0f> 0b 65 ff 05 41 89 e5 5f 48 8b 05 9a 0f 20 00 e8 1d 82 f7 e0 85
<4> [292.945543] RSP: 0018:ffffc90000c47de8 EFLAGS: 00010282
<4> [292.945556] RAX: 000000000000000f RBX: ffff88811bdc5e80 RCX: 0000000000000000
<4> [292.945569] RDX: 0000000000000001 RSI: 0000000000000008 RDI: ffff88813309bfc8
<4> [292.945582] RBP: ffff88811bdc62f0 R08: 0000000000063a7f R09: ffff888132829000
<4> [292.945596] R10: 0000000000000000 R11: ffff88813309bfc8 R12: ffff888119420000
<4> [292.945609] R13: ffff888119420068 R14: ffffffff82340628 R15: ffff88811bdc5f10
<4> [292.945623] FS:  0000000000000000(0000) GS:ffff888133b00000(0000) knlGS:0000000000000000
<4> [292.945638] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
<4> [292.945648] CR2: 0000555d734d44f4 CR3: 0000000002210000 CR4: 00000000000006e0
<4> [292.945662] Call Trace:
<4> [292.945738]  __i915_gem_free_work+0x5a/0x90 [i915]
<4> [292.945755]  process_one_work+0x245/0x610
<4> [292.945767]  worker_thread+0x37/0x380
<4> [292.945778]  ? process_one_work+0x610/0x610
<4> [292.945789]  kthread+0x119/0x130
<4> [292.945798]  ? kthread_park+0x80/0x80
<4> [292.945811]  ret_from_fork+0x3a/0x50
<4> [292.945824] Modules linked in: i915(-) vgem snd_hda_codec_hdmi snd_hda_codec_generic coretemp crct10dif_pclmul crc32_pclmul ghash_clmulni_intel snd_hda_codec snd_hwdep snd_hda_core e1000e snd_pcm mei_me ptp mei pps_core lpc_ich prime_numbers [last unloaded: i915]
<0> [292.988585] ---------------------------------
<4> [292.988747] ---[ end trace 23c463bff5e8ed92 ]---
<4> [292.988829] RIP: 0010:__i915_gem_free_objects+0x2be/0x730 [i915]
<4> [292.988843] Code: 21 b7 f6 e0 48 8b 35 49 af 1f 00 49 c7 c0 b0 39 2f a0 b9 ec 00 00 00 48 c7 c2 a0 d1 2c a0 48 c7 c7 b9 d4 1b a0 e8 82 7c fd e0 <0f> 0b 65 ff 05 41 89 e5 5f 48 8b 05 9a 0f 20 00 e8 1d 82 f7 e0 85
<4> [292.988875] RSP: 0018:ffffc90000c47de8 EFLAGS: 00010282
<4> [292.988890] RAX: 000000000000000f RBX: ffff88811bdc5e80 RCX: 0000000000000000
<4> [292.988907] RDX: 0000000000000001 RSI: 0000000000000008 RDI: ffff88813309bfc8
<4> [292.988922] RBP: ffff88811bdc62f0 R08: 0000000000063a7f R09: ffff888132829000
<4> [292.988939] R10: 0000000000000000 R11: ffff88813309bfc8 R12: ffff888119420000
<4> [292.988955] R13: ffff888119420068 R14: ffffffff82340628 R15: ffff88811bdc5f10
<4> [292.988971] FS:  0000000000000000(0000) GS:ffff888133b00000(0000) knlGS:0000000000000000
<4> [292.988987] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
<4> [292.988998] CR2: 0000555d734d44f4 CR3: 0000000121f34000 CR4: 00000000000006e0
Comment 1 CI Bug Log 2019-06-03 11:58:15 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* ILK: igt@i915_module_load@reload-with-fault-injection - incomplete - GEM_BUG_ON(i915_gem_object_has_pages(obj))
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5026/fi-ilk-m540/igt@i915_module_load@reload-with-fault-injection.html
Comment 2 Chris Wilson 2019-06-03 11:59:30 UTC
Just the messenger that someone leaked their pages.
Comment 3 Francesco Balestrieri 2019-06-10 10:29:28 UTC
Summarising IRC discussion with Chris:

The failure is caused by a memory leak, but it's not clear where it originated.  In order to find out, we would need to implement tracking of owners of the pages, but this means allocating someone's time to doing it.

In terms of user impact, it's hard to judge without knowing more details about the leak. If this would be e.g. one of the connector leaks seen before, it only shows at module unload and is therefore a minor issue. It was also seen only once in CI so far.
Comment 4 Chris Wilson 2019-06-20 19:15:50 UTC
Warning removed, quiet fixup instead,

commit 0bd6cb6b58f7332c61cef2e4ae48db1ca9910b6b
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Tue Jun 18 08:41:29 2019 +0100

    drm/i915: Skip shrinking already freed pages


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.