Bug 110835 - [i915] HDMI connector status is connected when plug out HDMI very slowly
Summary: [i915] HDMI connector status is connected when plug out HDMI very slowly
Status: RESOLVED DUPLICATE of bug 107125
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged, ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-04 02:00 UTC by Yvonne
Modified: 2019-06-14 08:42 UTC (History)
4 users (show)

See Also:
i915 platform: CFL
i915 features: display/HDMI


Attachments
amixer log after step23 (405 bytes, text/plain)
2019-06-04 02:38 UTC, Yvonne
no flags Details
HDMI_dmesg (178.34 KB, text/plain)
2019-06-04 02:39 UTC, Yvonne
no flags Details
HDMI_logger (62.06 KB, text/plain)
2019-06-04 02:39 UTC, Yvonne
no flags Details
HDMI_drm_dmesg.log (85.12 KB, text/plain)
2019-06-10 09:42 UTC, Yvonne
no flags Details
Update the HDMI_drm_dmesg from 0s (331.10 KB, text/plain)
2019-06-11 01:59 UTC, Yvonne
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yvonne 2019-06-04 02:00:16 UTC
Platform :CML laptop with codec ALC3204

Reproduce Steps:

1.Do system reboot
2.Plug in HDMI and check HDMI status via commad "amixer cget numid=37"
3.Plug out HDMI very slowly and check HDMI status via amixer cget numid=37

Frequency:100%

Expected result:
Sound setting update HDMI status (HDMI option disappeared) after step3

Actual result:
HDMI option still in Sound setting, and amixer cget numid=37 still shows value=on

Similar status as but patch at https://bugs.freedesktop.org/show_bug.cgi?id=107125 doesn't resolve the issue. Bug reproduced rate almost reach 100% if we plug out HDMI very slowly.

With HDA legacy driver, same symptom still exist.

Need to fix in graphics driver.
Comment 1 Yvonne 2019-06-04 02:38:16 UTC
Created attachment 144435 [details]
amixer log after step23
Comment 2 Yvonne 2019-06-04 02:39:12 UTC
Created attachment 144436 [details]
HDMI_dmesg
Comment 3 Yvonne 2019-06-04 02:39:33 UTC
Created attachment 144437 [details]
HDMI_logger
Comment 4 Lakshmi 2019-06-04 12:02:30 UTC
Clint, any comments on this bug?
Comment 5 Lakshmi 2019-06-06 06:21:29 UTC
(In reply to Yvonne from comment #0)
> Platform :CML laptop with codec ALC3204
> 
> Reproduce Steps:
> 
> 1.Do system reboot
> 2.Plug in HDMI and check HDMI status via commad "amixer cget numid=37"
> 3.Plug out HDMI very slowly and check HDMI status via amixer cget numid=37
> 
> Frequency:100%
> 
> Expected result:
> Sound setting update HDMI status (HDMI option disappeared) after step3
> 
> Actual result:
> HDMI option still in Sound setting, and amixer cget numid=37 still shows
> value=on
> 
> Similar status as but patch at
> https://bugs.freedesktop.org/show_bug.cgi?id=107125 doesn't resolve the
> issue. Bug reproduced rate almost reach 100% if we plug out HDMI very slowly.
> 
> With HDA legacy driver, same symptom still exist.
> 
> Need to fix in graphics driver.

@James, any suggestions here?
Comment 6 James Ausmus 2019-06-06 20:25:07 UTC
There was a recent email thread about this, here's Jani Nikula's response:

"We get a hotplug interrupt before the plug is completely out, while ddc
communication still works with the display, and we conclude we are still
connected. Moreover, the live status bits on the hotplug state have been
notoriously unreliable in the past, we've tried using them like three
times in the past, leading to regressions and reverts every time.

You can come up with all sorts of pathological slow plug/unplug/wiggle
cases. If you have a concrete requirement how slow needs to be okay, or
better yet write a test case for igt and chamelium, we can work with
that. We've proposed fixes in the past but they stalled because some
undisclosed unquantified test case still failed."
Comment 7 Lakshmi 2019-06-10 06:45:17 UTC
(In reply to Yvonne from comment #2)
> Created attachment 144436 [details]
> HDMI_dmesg
Can you please attach the dmesg from boot with kernel parameters drm.debug=0x1e log_buf_len=4M? Just in case, it might be helpful.

Also, as a user what is the impact of this issue?
Comment 8 Yvonne 2019-06-10 09:41:15 UTC
Catched the log you need. Please see the attachment HDMI_drc_dmesg.log with kernel parameters drm.debug=0x1e log_buf_len=4M.

As a user the impacts are as belows:
1. For audio. When issue occurred, system will always show HDMI option in sound setting and cannot auto switch to other output source if highlight HDMI before. 
2. For display. When issue occurred,screen which split before cannot back to normal.
Comment 9 Yvonne 2019-06-10 09:42:24 UTC
Created attachment 144490 [details]
HDMI_drm_dmesg.log
Comment 10 Lakshmi 2019-06-10 10:01:37 UTC
(In reply to Yvonne from comment #8)
> Catched the log you need. Please see the attachment HDMI_drc_dmesg.log with
> kernel parameters drm.debug=0x1e log_buf_len=4M.
> 
> As a user the impacts are as belows:
> 1. For audio. When issue occurred, system will always show HDMI option in
> sound setting and cannot auto switch to other output source if highlight
> HDMI before. 
> 2. For display. When issue occurred,screen which split before cannot back to
> normal.

Thanks for the explaining the impact. But, the dmesg is from the boot, can you attach from 0 seconds, currently its from 196 seconds.
Comment 11 Yvonne 2019-06-11 01:59:30 UTC
Created attachment 144497 [details]
Update the HDMI_drm_dmesg from 0s
Comment 12 Jani Nikula 2019-06-14 08:42:48 UTC

*** This bug has been marked as a duplicate of bug 107125 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.