Bug 110839 - [CI][SHARDS] igt@gem_ctx_shared@q-independent-bsd - skip - mmio base not known
Summary: [CI][SHARDS] igt@gem_ctx_shared@q-independent-bsd - skip - mmio base not known
Status: RESOLVED NOTABUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-05 07:01 UTC by Martin Peres
Modified: 2019-11-11 10:15 UTC (History)
1 user (show)

See Also:
i915 platform: ICL, KBL
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-06-05 07:01:01 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5033/shard-iclb1/igt@gem_ctx_shared@q-independent-bsd.html

Starting subtest: Q-independent-bsd
mmio base not known
Subtest Q-independent-bsd: SKIP (0.000s)
Comment 1 CI Bug Log 2019-06-05 07:02:03 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* CML ICL: igt@gem_ctx_shared@q-independent-bsd - skip - mmio base not known
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5033/shard-iclb1/igt@gem_ctx_shared@q-independent-bsd.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6183/shard-iclb8/igt@gem_ctx_shared@q-independent-bsd.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_3098/shard-iclb3/igt@gem_ctx_shared@q-independent-bsd.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_3099/shard-iclb3/igt@gem_ctx_shared@q-independent-bsd.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5034/shard-iclb4/igt@gem_ctx_shared@q-independent-bsd.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6184/shard-iclb6/igt@gem_ctx_shared@q-independent-bsd.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_3097/shard-iclb6/igt@gem_ctx_shared@q-independent-bsd.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_13165/shard-iclb6/igt@gem_ctx_shared@q-independent-bsd.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5035/shard-iclb5/igt@gem_ctx_shared@q-independent-bsd.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/TrybotIGT_25/shard-iclb5/igt@gem_ctx_shared@q-independent-bsd.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6186/re-cml-u/igt@gem_ctx_shared@q-independent-bsd.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5036/shard-iclb3/igt@gem_ctx_shared@q-independent-bsd.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6185/shard-iclb5/igt@gem_ctx_shared@q-independent-bsd.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_3101/shard-iclb1/igt@gem_ctx_shared@q-independent-bsd.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5037/shard-iclb6/igt@gem_ctx_shared@q-independent-bsd.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6187/re-icl-u/igt@gem_ctx_shared@q-independent-bsd.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6186/shard-iclb1/igt@gem_ctx_shared@q-independent-bsd.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_3100/shard-iclb7/igt@gem_ctx_shared@q-independent-bsd.html
Comment 2 CI Bug Log 2019-09-11 07:33:46 UTC
A CI Bug Log filter associated to this bug has been updated:

{- CML ICL: igt@gem_ctx_shared@q-independent-bsd - skip - mmio base not known -}
{+ CML ICL TGL: igt@gem_ctx_shared@q-independent-bsd - skip - mmio base not known +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_365/fi-tgl-u/igt@gem_ctx_shared@q-independent-bsd.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@gem_ctx_shared@q-independent-bsd.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@gem_ctx_shared@q-independent-bsd.html
Comment 3 Martin Peres 2019-09-11 07:34:16 UTC
Please explain why it is not a bug before closing.
Comment 4 Francesco Balestrieri 2019-11-11 10:15:34 UTC
The skip is legitimate in this case because the kernel is reporting correctly that the engine is not present and so the test shouldn't be run. The tricky part is that in some of the ICLs in shards, the engine is indeed present so the test can be run there and passes, explaining the flip-flops.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.