Bug 110860 - GPU HANG: ecode 7:1:0xfffffffe, in X [4283], hang on rcs0
Summary: GPU HANG: ecode 7:1:0xfffffffe, in X [4283], hang on rcs0
Status: RESOLVED DUPLICATE of bug 111014
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-08 16:03 UTC by pkozlov
Modified: 2019-07-02 19:23 UTC (History)
1 user (show)

See Also:
i915 platform: IVB
i915 features: GPU hang


Attachments
/sys/class/drm/card0/error (35.26 KB, text/plain)
2019-06-08 16:03 UTC, pkozlov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pkozlov 2019-06-08 16:03:53 UTC
Created attachment 144484 [details]
/sys/class/drm/card0/error

I have noticed GPU hang in dmesg, but saw no other evidence that something could be wrong... video was fine. Could be false alarm?

[39024.697788] i915 0000:00:02.0: GPU HANG: ecode 7:1:0xfffffffe, in X [4283], hang on rcs0
[39024.697790] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[39024.697791] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[39024.697792] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[39024.697792] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[39024.697793] [drm] GPU crash dump saved to /sys/class/drm/card0/error

xorg-server version 1.20.4
Comment 1 Chris Wilson 2019-07-02 19:23:48 UTC
Please test with

commit c84c9029d782a3a0d2a7f0522ecb907314d43e2c
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Fri Apr 19 12:17:47 2019 +0100

    drm/i915/ringbuffer: EMIT_INVALIDATE *before* switch context

heading to v5.1 via stable in the next few weeks.

*** This bug has been marked as a duplicate of bug 111014 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.