Bug 110870 - [CI][SHARDS] igt@kms_mmap_write_crc@main - fail - Failed assertion: !mismatch
Summary: [CI][SHARDS] igt@kms_mmap_write_crc@main - fail - Failed assertion: !mismatch
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-10 08:27 UTC by Martin Peres
Modified: 2019-07-30 08:29 UTC (History)
1 user (show)

See Also:
i915 platform: SKL
i915 features: display/Other, GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-06-10 08:27:27 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6211/shard-skl8/igt@kms_mmap_write_crc@main.html

Starting subtest: main
(kms_mmap_write_crc:2939) igt_debugfs-CRITICAL: Test assertion failure function igt_assert_crc_equal, file ../lib/igt_debugfs.c:419:
(kms_mmap_write_crc:2939) igt_debugfs-CRITICAL: Failed assertion: !mismatch
Comment 1 Martin Peres 2019-06-10 08:28:35 UTC
Adding GEM here since there were changes recently with regards to local memory which could explain the mismatch!
Comment 3 Francesco Balestrieri 2019-07-30 04:35:24 UTC
Matt, do you see anything in the local memory code that could have affected this?

Martin, is there something specific you suspect in the lmem code?

BTW the logs at https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6211/shard-skl8/igt@kms_mmap_write_crc@main.html are no longer accessible (404)
Comment 4 Lakshmi 2019-07-30 08:29:15 UTC
(In reply to Francesco Balestrieri from comment #3)
> Matt, do you see anything in the local memory code that could have affected
> this?
> 
> Martin, is there something specific you suspect in the lmem code?
> 
> BTW the logs at
> https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6211/shard-skl8/
> igt@kms_mmap_write_crc@main.html are no longer accessible (404)

Reproduction rate of this failure is once in 5.75 runs. Last seen on CI_DRM_6223_full and current run is CI_DRM_6576.

Closing this issue as WORKSFORME.
Comment 5 CI Bug Log 2019-07-30 08:29:22 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.