Bug 110880 - [CI][RESUME] igt@kms_chamelium@hdmi-audio - fail - Failed assertion: ok
Summary: [CI][RESUME] igt@kms_chamelium@hdmi-audio - fail - Failed assertion: ok
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high normal
Assignee: emersion
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-10 12:09 UTC by Martin Peres
Modified: 2019-06-13 10:47 UTC (History)
1 user (show)

See Also:
i915 platform: ICL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-06-10 12:09:20 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6216/re-icl-u/igt@kms_chamelium@hdmi-audio.html

Starting subtest: hdmi-audio
Home directory not accessible: Permission denied
(kms_chamelium:1235) igt_chamelium_stream-WARNING: read failed: Resource temporarily unavailable
(kms_chamelium:1235) CRITICAL: Test assertion failure function audio_state_receive, file ../tests/kms_chamelium.c:964:
(kms_chamelium:1235) CRITICAL: Failed assertion: ok
(kms_chamelium:1235) CRITICAL: Last errno: 11, Resource temporarily unavailable

Would be nice to change the assertion to something more meaningful (or add a message to it).
Comment 1 Martin Peres 2019-06-10 12:10:06 UTC
Assigning Simon Ser since he introduced the code :)
Comment 2 CI Bug Log 2019-06-10 12:10:16 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* CHAMELIUM: igt@kms_chamelium@hdmi-audio - fail - Failed assertion: ok
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6216/re-icl-u/igt@kms_chamelium@hdmi-audio.html
Comment 3 emersion 2019-06-10 12:12:39 UTC
I've noticed this bug as well. After investigation it turned out to be a Chamelium bug. I sent a patch: https://chromium-review.googlesource.com/c/chromiumos/platform/chameleon/+/1649748

The Chamelium device on re-icl-u now has the patch so we shouldn't see this one anymore.
Comment 4 Martin Peres 2019-06-10 12:30:33 UTC
(In reply to emersion from comment #3)
> I've noticed this bug as well. After investigation it turned out to be a
> Chamelium bug. I sent a patch:
> https://chromium-review.googlesource.com/c/chromiumos/platform/chameleon/+/
> 1649748
> 
> The Chamelium device on re-icl-u now has the patch so we shouldn't see this
> one anymore.

Thanks!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.