Bug 110890 - [CI][SHARDS] igt@gem_ctx_shared@exec-shared-gtt-default - fail - Failed assertion: *batch == 0xc0ffee
Summary: [CI][SHARDS] igt@gem_ctx_shared@exec-shared-gtt-default - fail - Failed asser...
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: high normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
: 110935 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-06-11 07:55 UTC by Martin Peres
Modified: 2019-06-24 07:46 UTC (History)
2 users (show)

See Also:
i915 platform: BXT
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-06-11 07:55:02 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5046/shard-apl6/igt@gem_ctx_shared@exec-shared-gtt-default.html

Starting subtest: exec-shared-gtt-default
(gem_ctx_shared:2958) CRITICAL: Test assertion failure function exec_shared_gtt, file ../tests/i915/gem_ctx_shared.c:241:
(gem_ctx_shared:2958) CRITICAL: Failed assertion: *batch == 0xc0ffee
(gem_ctx_shared:2958) CRITICAL: error: 0x5000000 != 0xc0ffee
Comment 1 CI Bug Log 2019-06-11 07:55:33 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* APL: igt@gem_ctx_shared@exec-shared-gtt-default - fail - Failed assertion: *batch == 0xc0ffee
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5046/shard-apl6/igt@gem_ctx_shared@exec-shared-gtt-default.html
Comment 2 Chris Wilson 2019-06-11 08:27:33 UTC
https://patchwork.freedesktop.org/series/61882/
Comment 3 Chris Wilson 2019-06-14 13:59:48 UTC
Hopefully,

commit 3b91c82b90d45c1a30569410c1142b541956740a (HEAD, upstream/master)
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Tue Jun 11 09:13:30 2019 +0100

    i915/gem_ctx_shared: Prefer explicit domain control
    
    Since we are fiddling behind the scenes, we are writing to objects that
    are not part of the execbuffer, do not rely on implicit domain
    management being able to track the appropriate CPU cache status.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=110890
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
    Reviewed-by: Mika Kuoppala <mika.kuoppala@linux.intel.com>
Comment 4 Chris Wilson 2019-06-18 07:22:38 UTC
*** Bug 110935 has been marked as a duplicate of this bug. ***
Comment 5 CI Bug Log 2019-06-24 07:45:24 UTC
A CI Bug Log filter associated to this bug has been updated:

{- APL: igt@gem_ctx_shared@exec-shared-gtt-default - fail - Failed assertion: *batch == 0xc0ffee -}
{+ BSW APL GLK: igt@gem_ctx_shared@exec-shared-gtt-(default|bsd) - fail - Failed assertion: *(s|batch) == 0xc0ffee +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6308/shard-glk4/igt@gem_ctx_shared@exec-shared-gtt-bsd.html
Comment 6 CI Bug Log 2019-06-24 07:46:47 UTC
A CI Bug Log filter associated to this bug has been updated:

{- BSW APL GLK: igt@gem_ctx_shared@exec-shared-gtt-(default|bsd) - fail - Failed assertion: *(s|batch) == 0xc0ffee -}
{+ BSW APL GLK: igt@gem_ctx_shared@exec-shared-gtt-* - fail - Failed assertion: *(s|batch) == 0xc0ffee +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_311/fi-bsw-n3050/igt@gem_ctx_shared@exec-shared-gtt-render.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6320/shard-apl6/igt@gem_ctx_shared@exec-shared-gtt-bsd1.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_314/fi-glk-dsi/igt@gem_ctx_shared@exec-shared-gtt-bsd1.html


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.