Bug 110900 - [CI][BAT] igt@i915_module_load@reload-with-fault-injection - dmesg-warn - WARN_ON(!queue_delayed_work(system_unbound_wq, &power_domains->async_put_work, msecs_to_jiffies(100)))
Summary: [CI][BAT] igt@i915_module_load@reload-with-fault-injection - dmesg-warn - WAR...
Status: RESOLVED DUPLICATE of bug 111012
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: highest normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-12 08:22 UTC by Martin Peres
Modified: 2019-07-12 14:35 UTC (History)
1 user (show)

See Also:
i915 platform: BSW/CHT
i915 features: power/Other, power/runtime PM


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-06-12 08:22:10 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6242/fi-bsw-kefka/igt@i915_module_load@reload-with-fault-injection.html

<7> [366.354770] [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x71450064
<4> [366.354968] ------------[ cut here ]------------
<4> [366.355000] WARN_ON(!queue_delayed_work(system_unbound_wq, &power_domains->async_put_work, msecs_to_jiffies(100)))
<4> [366.355167] WARNING: CPU: 0 PID: 3069 at drivers/gpu/drm/i915/intel_display_power.c:1800 queue_async_put_domains_work+0x65/0x70 [i915]
<4> [366.355173] Modules linked in: i915(-) vgem snd_hda_codec_hdmi asix coretemp crct10dif_pclmul usbnet crc32_pclmul mii ghash_clmulni_intel btusb btrtl btbcm btintel bluetooth ecdh_generic ecc lpc_ich snd_hda_codec snd_hwdep snd_hda_core snd_pcm prime_numbers pinctrl_cherryview [last unloaded: i915]
<4> [366.355218] CPU: 0 PID: 3069 Comm: kworker/0:0 Tainted: G     U            5.2.0-rc4-CI-CI_DRM_6242+ #1
<4> [366.355223] Hardware name: GOOGLE Kefka/Kefka, BIOS MrChromebox 02/04/2018
<4> [366.355237] Workqueue: events output_poll_execute
<4> [366.355328] RIP: 0010:queue_async_put_domains_work+0x65/0x70 [i915]
<4> [366.355335] Code: 48 c7 c6 08 85 38 a0 48 c7 c7 aa 88 3a a0 e8 62 8b df e0 0f 0b eb bf 48 c7 c6 38 85 38 a0 48 c7 c7 aa 88 3a a0 e8 4b 8b df e0 <0f> 0b 5b 5d c3 66 0f 1f 44 00 00 0f b6 4e 28 48 8b 46 20 ba 01 00
<4> [366.355341] RSP: 0018:ffffc900002db958 EFLAGS: 00010286
<4> [366.355348] RAX: 0000000000000000 RBX: ffff88816488a1c0 RCX: 0000000000000000
<4> [366.355354] RDX: 000000000000167b RSI: ffff888176eb09f8 RDI: ffffffff8212df61
<4> [366.355360] RBP: 00000000c1800003 R08: 00000000ff6c2682 R09: 0000000000000000
<4> [366.355365] R10: 0000000000000000 R11: 0000000000000000 R12: 0000000000000020
<4> [366.355371] R13: 00000000c1800003 R14: ffff88816488a1c0 R15: 00000000c0c00003
<4> [366.355377] FS:  0000000000000000(0000) GS:ffff88817ba00000(0000) knlGS:0000000000000000
<4> [366.355383] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
<4> [366.355389] CR2: 00007f93d547c118 CR3: 000000016c612000 CR4: 00000000001006f0
<4> [366.355394] Call Trace:
<4> [366.355489]  __intel_display_power_put_async+0xb6/0xf0 [i915]
<4> [366.355585]  intel_dp_aux_xfer+0x19d/0x8c0 [i915]
<4> [366.355614]  ? wait_woken+0xa0/0xa0
<4> [366.355716]  intel_dp_aux_transfer+0xa7/0x200 [i915]
<4> [366.355735]  drm_dp_dpcd_access+0x76/0x110
<4> [366.355755]  drm_dp_dpcd_read+0x29/0xc0
<4> [366.355848]  intel_dp_read_dpcd+0x38/0x120 [i915]
<4> [366.355941]  intel_dp_get_dpcd+0x1d/0xe0 [i915]
<4> [366.356031]  intel_dp_detect+0x2c0/0x5e0 [i915]
<4> [366.356052]  drm_helper_probe_single_connector_modes+0xd4/0x6e0
<4> [366.356095]  drm_client_modeset_probe+0x257/0xad0
<4> [366.356117]  ? drm_dbg+0x7f/0x90
<4> [366.356142]  drm_fb_helper_hotplug_event.part.12+0x95/0xc0
<4> [366.356152]  drm_kms_helper_hotplug_event+0x21/0x30
<4> [366.356161]  output_poll_execute+0x1a0/0x1b0
<4> [366.356181]  process_one_work+0x245/0x610
<4> [366.356203]  worker_thread+0x37/0x380
<4> [366.356217]  ? process_one_work+0x610/0x610
<4> [366.356224]  kthread+0x119/0x130
<4> [366.356232]  ? kthread_park+0x80/0x80
<4> [366.356247]  ret_from_fork+0x3a/0x50
<4> [366.356278] irq event stamp: 40570
<4> [366.356287] hardirqs last  enabled at (40569): [<ffffffff8112867c>] vprintk_emit+0xcc/0x340
<4> [366.356295] hardirqs last disabled at (40570): [<ffffffff810019e0>] trace_hardirqs_off_thunk+0x1a/0x1c
<4> [366.356303] softirqs last  enabled at (40548): [<ffffffff81c0033a>] __do_softirq+0x33a/0x4b9
<4> [366.356311] softirqs last disabled at (40539): [<ffffffff810b6399>] irq_exit+0xa9/0xc0
<4> [366.356401] WARNING: CPU: 0 PID: 3069 at drivers/gpu/drm/i915/intel_display_power.c:1800 queue_async_put_domains_work+0x65/0x70 [i915]
<4> [366.356407] ---[ end trace 41e634b3f1908b3c ]---
Comment 1 CI Bug Log 2019-06-12 08:23:01 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* BSW: igt@i915_module_load@reload-with-fault-injection - dmesg-warn - WARN_ON(!queue_delayed_work(system_unbound_wq, &amp;power_domains-&gt;async_put_work, msecs_to_jiffies(100)))
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6242/fi-bsw-kefka/igt@i915_module_load@reload-with-fault-injection.html
Comment 2 Chris Wilson 2019-07-12 14:35:07 UTC
commit 315ca4c408ed3bcfe3a204fec9f5c397a98e97a0
Author: Ville Syrjälä <ville.syrjala@linux.intel.com>
Date:   Tue Jul 2 18:17:23 2019 +0300

    drm/i915: synchronize_irq() against the actual irq
    
    When eliminating our use of drm_irq_install() I failed to convert
    all our synchronize_irq() calls to consult pdev->irq instead of
    dev_priv->drm.irq. As we no longer populate dev_priv->drm.irq
    we're no longer synchronizing against anything.
    
    v2: Add intel_syncrhonize_irq() (Chris)
    
    Cc: Chris Wilson <chris@chris-wilson.co.uk>
    Reported-by: Imre Deak <imre.deak@intel.com>
    Fixes: b318b82455bd ("drm/i915: Nuke drm_driver irq vfuncs")
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=111012
    Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
    Signed-off-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
    Link: https://patchwork.freedesktop.org/patch/msgid/20190702151723.29739-1-ville.syrjala@linux.intel.com

*** This bug has been marked as a duplicate of bug 111012 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.