Bug 110924 - Alien: Isolation - Flashing squares in upper half of screen when HDAO enabled
Summary: Alien: Isolation - Flashing squares in upper half of screen when HDAO enabled
Status: RESOLVED DUPLICATE of bug 108919
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-15 11:18 UTC by James Le Cuirot
Modified: 2019-07-08 03:39 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Screenshot showing artifacts (280.06 KB, image/jpeg)
2019-06-15 11:18 UTC, James Le Cuirot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Le Cuirot 2019-06-15 11:18:19 UTC
Created attachment 144551 [details]
Screenshot showing artifacts

This game worked perfectly for me around a year ago. Now it shows strange flashing/moving mostly black squares in the upper half of the screen when HDAO is enabled. Please see the attached screenshot. It looks worse when you move. Choosing "standard" SSAO instead makes the problem go away.

I'm not alone, here is another Steam user reporting the same thing:
https://steamcommunity.com/app/214490/discussions/0/1735468061769831062/

Here are my system details:
OpenGL vendor string: X.Org
OpenGL renderer string: AMD Radeon (TM) RX 480 Graphics (POLARIS10, DRM 3.30.0, 5.1.10-00004-g8b7bb440229b, LLVM 8.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 19.2.0-devel (git-749c544b84)
OpenGL core profile shading language version string: 4.50

It still happens with Mesa as far back as 18.2.0. Anything earlier just crashes on my system but the other user reported he was using 18.1.9. I have tried against LLVM 6, 7, and 8 with no change. I have also booted into a Fedora 28 Live USB system, chrooted into my Gentoo system, and it still happens. It's possibly down a change in the game itself although I can't verify that and I don't think it's seeing many changes these days.

Sorry if I've assigned this to the wrong component but it's hard to say where the problem lies.
Comment 1 Timothy Arceri 2019-07-08 03:39:27 UTC

*** This bug has been marked as a duplicate of bug 108919 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.