Bug 110933 - [CI][DRMTIP] igt@i915_pm_rc6_residency@* - skip - est requirement: wait_for_rc6()
Summary: [CI][DRMTIP] igt@i915_pm_rc6_residency@* - skip - est requirement: wait_for_r...
Status: RESOLVED DUPLICATE of bug 110877
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-18 04:44 UTC by Lakshmi
Modified: 2019-08-05 06:55 UTC (History)
2 users (show)

See Also:
i915 platform: ICL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-06-18 04:44:30 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_310/fi-icl-guc/igt@i915_pm_rc6_residency@media-rc6-accuracy.html

Test requirement not met in function __real_main198, file ../tests/i915/i915_pm_rc6_residency.c:217:
Test requirement: wait_for_rc6()
Subtest media-rc6-accuracy: SKIP

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_310/fi-icl-guc/igt@i915_pm_rc6_residency@rc6-accuracy.html

Test requirement not met in function __real_main198, file ../tests/i915/i915_pm_rc6_residency.c:217:
Test requirement: wait_for_rc6()
Subtest rc6-accuracy: SKIP
Comment 1 CI Bug Log 2019-06-18 04:45:40 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* ICL: igt@i915_pm_rc6_residency@* - skip - est requirement: wait_for_rc6()
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_310/fi-icl-guc/igt@i915_pm_rc6_residency@media-rc6-accuracy.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_310/fi-icl-guc/igt@i915_pm_rc6_residency@rc6-accuracy.html
Comment 2 Lakshmi 2019-08-01 11:51:50 UTC
This bug needs assessment, can you please help here?
Comment 3 Don Hiatt 2019-08-02 20:55:16 UTC
The test 'tests/i915/i915_pm_rc6_residency.c' is asserting in wait_for_rc6(). That function basically reads the current rc6 residency count, pauses and reads it again. For success, the there must be a difference in those to reads, e.g. the rc6 residency count must have incremented. In this case, the machine is not entering rc6 as expected. Something (e.g. audio) must be holding a wakeref and preventing rc6.
Comment 4 CI Bug Log 2019-08-05 06:49:59 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@i915_pm_rc6_residency@* - skip - est requirement: wait_for_rc6() -}
{+ GUC: igt@i915_pm_rc6_residency@* - skip - est requirement: wait_for_rc6() +}


  No new failures caught with the new filter
Comment 5 Lakshmi 2019-08-05 06:55:15 UTC

*** This bug has been marked as a duplicate of bug 110877 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.