Bug 110944 - [Bisected] Blender 2.8 crashes when closing certain windows
Summary: [Bisected] Blender 2.8 crashes when closing certain windows
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: 19.1
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-18 14:42 UTC by Sebastian Parborg
Modified: 2019-07-09 09:39 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Git bisect log (2.33 KB, text/plain)
2019-06-18 14:42 UTC, Sebastian Parborg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Parborg 2019-06-18 14:42:36 UTC
Created attachment 144589 [details]
Git bisect log

I'm running wayland/swaywm with two Vega 64s.
After I upgraded to mesa 19.1 I noticed that Blender 2.8 would crash when closing certain windows (and only when it would trigger a resize of the remaining Blender windows).

Blender bug here: https://developer.blender.org/T65903

I noticed that this wasn't the case with mesa 19.0.6 so I bisected and it seems like this commit is the cause of the crashing:

593e36f9561d3665cc12ed1fc8a07dd8612c004e

I also tested the latest mesa git master, and the crash still happens.
Comment 1 Pierre-Eric Pelloux-Prayer 2019-06-18 14:50:19 UTC
Can you test the commit from https://gitlab.freedesktop.org/mesa/mesa/merge_requests/1071? I think it should fix this issue.
Comment 2 Sebastian Parborg 2019-06-18 14:59:23 UTC
Yes that patch seems to solve the issue!
Comment 3 Juan A. Suarez 2019-07-09 09:39:46 UTC
The patch has been released also with Mesa 19.1.2.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.