Bug 110945 - [ICL] GPU hang with piglit test spec.arb_compute_shader.execution.shared-atomicmax-uint
Summary: [ICL] GPU hang with piglit test spec.arb_compute_shader.execution.shared-atom...
Status: RESOLVED NOTOURBUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/Iris (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-18 16:27 UTC by Clayton Craft
Modified: 2019-06-25 23:55 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
error state (23.34 KB, text/plain)
2019-06-18 16:50 UTC, Clayton Craft
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Clayton Craft 2019-06-18 16:27:03 UTC
This test seems to reliably cause a gpu hang on ICL.

Test output: 

/tmp/build_root/m64/lib/piglit/bin/shader_runner /tmp/build_root/m64/lib/piglit/tests/spec/arb_compute_shader/execution/shared-atomicMax-uint.shader_test -auto -fbo
piglit: debug: Requested an OpenGL 3.3 Core Context, and received a matching 4.5 context

Atomic counter 0 test failed: Reference == Observed
  Reference: 0
  Observed:  60
Test failure on line 137
Comment 1 Clayton Craft 2019-06-18 16:50:17 UTC
Created attachment 144590 [details]
error state
Comment 2 Tapani Pälli 2019-06-19 07:07:06 UTC
This test seems to pass reliably for me, I have PCI ID 0x8a56 using Mesa @ a7f75377aba and drm-tip 5.2.0-rc5+
Comment 3 Tapani Pälli 2019-06-19 07:07:46 UTC
(In reply to Tapani Pälli from comment #2)
> This test seems to pass reliably for me, I have PCI ID 0x8a56 using Mesa @
> a7f75377aba and drm-tip 5.2.0-rc5+

Argh sorry, this was on i965.
Comment 4 Tapani Pälli 2019-06-24 09:55:05 UTC
(In reply to Tapani Pälli from comment #3)
> (In reply to Tapani Pälli from comment #2)
> > This test seems to pass reliably for me, I have PCI ID 0x8a56 using Mesa @
> > a7f75377aba and drm-tip 5.2.0-rc5+
> 
> Argh sorry, this was on i965.

Having said that, this test seems to reliably pass for me on Iris as well, Mesa @ 946193ae008.
Comment 5 Tapani Pälli 2019-06-24 11:44:42 UTC
Clayton, what kernel version was used? I see no hangs even with quite old Mesa so I'm suspecting something might have been fixed at kernel side?
Comment 6 Clayton Craft 2019-06-24 17:04:26 UTC
I was using a drm-tip kernel from March of this year. I am hoping to update the kernel on the ICL systems in CI, along with the bios, so maybe this (plus some of the other gpu hangs) will be resolved. It's good to know you cannot reproduce this on a newer kernel though, it gives me hope!
Comment 7 Clayton Craft 2019-06-25 23:55:11 UTC
I'm not able to reproduce the gpu hang using drm-tip kernel + newer platform BIOS.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.