Bug 110991 - [CI][DRMTIP] igt@kms_content_protection@* - fail - Failed assertion: ret, Content Protection not enabled
Summary: [CI][DRMTIP] igt@kms_content_protection@* - fail - Failed assertion: ret, Con...
Status: RESOLVED NOTOURBUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Ramalingam C
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-25 10:16 UTC by Lakshmi
Modified: 2019-07-08 13:39 UTC (History)
2 users (show)

See Also:
i915 platform: ICL
i915 features: display/HDCP


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-06-25 10:16:02 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_315/fi-icl-u3/igt@kms_content_protection@atomic.html

Starting subtest: atomic
(kms_content_protection:1893) CRITICAL: Test assertion failure function test_cp_enable_with_retry, file ../tests/kms_content_protection.c:219:
(kms_content_protection:1893) CRITICAL: Failed assertion: ret
(kms_content_protection:1893) CRITICAL: Content Protection not enabled
Subtest atomic failed.
Comment 2 Ramalingam C 2019-07-08 13:39:51 UTC
As per https://patchwork.freedesktop.org/series/63023/ this issue is caused because device connected at DP port declared itself as a repeater with zero HDCP sinks connected to it. So I915 is reacting as it supposed to be by failing the HDCP authentication.

So not an I915 Bug.

To capture this root cause in the debug log new change is submitted at https://patchwork.freedesktop.org/series/63217/. Will be merged when the review is completed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.