Bug 111020 - [RADV][DXVK] GPU lockup on Risk of Rain 2
Summary: [RADV][DXVK] GPU lockup on Risk of Rain 2
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/radeon (show other bugs)
Version: 19.1
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-28 20:46 UTC by MayeulC
Modified: 2019-09-18 20:07 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MayeulC 2019-06-28 20:46:37 UTC
# System specs
GPU: R9 Fury
Distribution: Arch Linux
Mesa: 19.1.1
LLVM: 8.0.0
Application: Risk of Rain 2 via Steamplay/Proton 4.2-9
Steam store URL: https://store.steampowered.com/app/632360/Risk_of_Rain_2/

# Steps to reproduce:
-Install Steam for Linux;
-Join Steam Beta;
-Enable Steam Play for all titles;
-Install Risk of Rain 2;
-Play Risk of Rain 2 to the third stage (it needs to have trees like the picture on the following page: https://steamcommunity.com/games/632360/announcements/detail/1595878665982945764 )
- The crash should happen within two minutes


# Notes
I encountered multiple random GPU hangs on this game before (~1 every 5 hours), but the latest update added an alternative third-stage level where I could not play longer than approximately 2 minutes without encountering a hang.

Unfortunately, the GPU does not recover, and I have to force-reboot the computer.

Do not hesitate to ask me additional information, with steps on how to gather it.
I thought about recording an apitrace, but this probably wouldn't play well with the GPU hang. I am not sure whether the issue is in LLVM or this should be preventable at the amdgpu-level. Though GPU recovery should probably work in the first place (I saw a patch to improve this pass by, but didn't try it).

Another game I'm getting random hangs in is No Man's Sky, also unrecoverable. I am reporting this one since it seems to be more reproducible.
Comment 1 Samuel Pitoiset 2019-08-21 11:41:26 UTC
Are you still able to reproduce the problem?
Comment 2 GitLab Migration User 2019-09-18 20:07:10 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/864.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.