Bug 111025 - Constant kernel crashes while playing Dota 2
Summary: Constant kernel crashes while playing Dota 2
Status: RESOLVED NOTOURBUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-30 03:10 UTC by Felipe Contreras
Modified: 2019-06-30 16:49 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Logs of 4 crashes. (16.52 KB, text/plain)
2019-06-30 03:10 UTC, Felipe Contreras
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Felipe Contreras 2019-06-30 03:10:29 UTC
Created attachment 144684 [details]
Logs of 4 crashes.

Since a while ago I've been constantly getting crashes playing Dota 2. Sometimes the game crashes, sometimes something else crashes, but most of the time the whole kernel crashes.

Unfortunately I cleaned the past logs, but I have four instances in my history (attached). It's very easy to reproduce, I just play for a while, and boom, kernel crash, after which I can't do anything but reboot.

All the instances show a crash in _kmalloc_node after i915_gem_execbuffer2_ioctl.

kernel: 4.19.49-1-MANJARO
Driver: Intel Open Source Technology Center Mesa DRI Intel(R) HD Graphics 620 (Kaby Lake GT2) x86/MMX/SSE2

Also, other people seem to be experiencing the same issue: https://github.com/ValveSoftware/Dota-2/issues/1616
Comment 1 Chris Wilson 2019-06-30 09:29:39 UTC
That is an issue with the tracepoints. I would double check that the code is compiled correctly, and do a bisect -- if the problem is still evident on a recent kernel.
Comment 2 Felipe Contreras 2019-06-30 16:49:23 UTC
(In reply to Chris Wilson from comment #1)
> That is an issue with the tracepoints. I would double check that the code is
> compiled correctly, and do a bisect -- if the problem is still evident on a
> recent kernel.

Let me get this straight: a kernel *CRASH* that people experience in the real world is not a bug?

And you don't consider 4.19.49 to be a recent kernel? A kernel released three weeks ago is not recent?

You ask me to check that the code is compiled correctly... How? Here is the config file:

https://gitlab.manjaro.org/packages/core/linux419/raw/master/config

What am I supposed to be checking in that 9.9k lines long file?

Then you ask me to do a bisect. From where?

I'm sure the people experiencing system crashes will appreciate the fact that you have "resolved" this bug.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.