Bug 111031 - [CI][DRMTIP] igt@kms_chamelium@hdmi-audio - dmesg-fail -Failed assertion: ok, Failed to receive audio from stream server
Summary: [CI][DRMTIP] igt@kms_chamelium@hdmi-audio - dmesg-fail -Failed assertion: ok,...
Status: NEW
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-01 08:20 UTC by Lakshmi
Modified: 2019-09-13 13:05 UTC (History)
1 user (show)

See Also:
i915 platform: KBL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-07-01 08:20:33 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_318/fi-kbl-7500u/igt@kms_chamelium@hdmi-audio.html

Starting subtest: hdmi-audio
Home directory not accessible: Permission denied
(kms_chamelium:1253) igt_chamelium_stream-WARNING: read failed: Resource temporarily unavailable
(kms_chamelium:1253) CRITICAL: Test assertion failure function audio_state_receive, file ../tests/kms_chamelium.c:968:
(kms_chamelium:1253) CRITICAL: Failed assertion: ok
(kms_chamelium:1253) CRITICAL: Last errno: 11, Resource temporarily unavailable
(kms_chamelium:1253) CRITICAL: Failed to receive audio from stream server
Subtest hdmi-audio failed.
Comment 1 CI Bug Log 2019-07-01 08:22:23 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* igt@kms_chamelium@hdmi-audio - dmesg-fail -Failed assertion: ok, Failed to receive audio from stream server
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_318/fi-kbl-7500u/igt@kms_chamelium@hdmi-audio.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_319/fi-kbl-7500u/igt@kms_chamelium@hdmi-audio.html
Comment 2 emersion 2019-07-16 14:00:51 UTC
Seems like a Chamelium bug. Chamelium logs:

2018-05-05 17:55:48,955 ERROR Failed to stop capturing audio: No audio data was captured. Perhaps this in
put is not plugged ?
Comment 3 emersion 2019-07-16 14:02:29 UTC
Ah, and this happens because we don't receive any data from the Chamelium via the streaming server. read hits the 5sec timeout.
Comment 4 emersion 2019-08-16 12:56:40 UTC
This issue is specific to fi-kbl-7500u. It's hit every week.

User impact: worst case scenario, no audio via HDMI.
Comment 5 emersion 2019-09-12 10:51:59 UTC
This patch might help understand what's going on: https://patchwork.freedesktop.org/series/66592/


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.