Bug 111066 - [CI][DRMTIP] igt@kms_content_protection@atomic - skip - No connector found with HDCP capability
Summary: [CI][DRMTIP] igt@kms_content_protection@atomic - skip - No connector found wi...
Status: RESOLVED NOTABUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-04 12:49 UTC by Lakshmi
Modified: 2019-09-17 09:16 UTC (History)
3 users (show)

See Also:
i915 platform: ICL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-07-04 12:49:15 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_320/fi-icl-u4/igt@kms_content_protection@atomic.html

Starting subtest: atomic
Test requirement not met in function test_content_protection, file ../tests/kms_content_protection.c:348:
Test requirement: valid_tests
No connector found with HDCP capability
Subtest atomic: SKIP (0.000s)
Comment 2 Uma Shankar 2019-07-10 18:33:21 UTC
This is expected if we don't connect a HDCP capable monitor to DUT.  Looks like we are executing these tests on non HDCP monitors and hitting this error. If someone can confirm that this indeed is the case, then we can close this as expected behavior and this should be a legitimate skip.
Comment 3 Lakshmi 2019-07-11 05:50:35 UTC
@Tomi, Can you confirm if the monitor connected to icl-u4 is HDCP capable?
Comment 4 Ramalingam C 2019-07-11 12:19:28 UTC
icl-u4 is newly added? couldn't find at https://intel-gfx-ci.01.org/hardware.html

If this fi-icl-u4 stands for fi-icl-y then this is expected as only eDP is connected to the machine and no HDMI/DP panel is there.
Comment 5 Tomi Sarvela 2019-07-11 14:19:40 UTC
Host fi-icl-u4 has two USB-C ports connected to Chamelium, through one HDMI and one DP dongle.

Chamelium is (to my knowledge) not HDCP capable.
Comment 6 CI Bug Log 2019-07-16 09:07:56 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@kms_content_protection@atomic - skip - No connector found with HDCP capability -}
{+ ICL: igt@kms_content_protection@atomic - skip - No connector found with HDCP capability +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_322/fi-icl-u4/igt@kms_content_protection@atomic-dpms.html
Comment 7 Anshuman Gupta 2019-07-19 05:23:47 UTC
BA Chameleon Board supports HDCP 1.4 on HDMI connector and  it does not HDCP capable on DP connector.
root@linux-Skylake-Client-platform:/home/linux# cat /sys/kernel/debug/dri/0/HDMI-A-1/i915_hdcp_sink_capability
HDMI-A-1:92 HDCP version: HDCP1.4
root@linux-Skylake-Client-platform:/home/linux# cat /sys/kernel/debug/dri/0/DP-1/i915_hdcp_sink_capability
DP-1:100 HDCP version: None
root@linux-Skylake-Client-platform:/home/linux#
Comment 8 Anshuman Gupta 2019-07-19 05:37:49 UTC
From the DMESG logs https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_322/fi-icl-u4/igt@kms_content_protection@atomic-dpms.html
it evident that only DP3 connector was connected and there was no HDMI connecotr conencted. which indicates it is a vaild skip.
Comment 9 Ramalingam C 2019-07-19 05:40:35 UTC
Based on the above system info and the results from debugging, Marking this as NOTABUG.
Comment 11 Lakshmi 2019-08-07 07:50:21 UTC
(In reply to CI Bug Log from comment #10)
> A CI Bug Log filter associated to this bug has been updated:
> 
> {- ICL: igt@kms_content_protection@atomic - skip - No connector found with
> HDCP capability -}
> {+ ICL: igt@kms_content_protection@atomic - skip - No connector found with
> HDCP capability +}
> 
> New failures caught by the filter:
> 
>   *
> https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5123/shard-iclb1/
> igt@kms_content_protection@srm.html
>   *
> https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5123/shard-iclb3/
> igt@kms_content_protection@lic.html
>   *
> https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5123/shard-iclb4/
> igt@kms_content_protection@content_type_change.html
>   *
> https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5123/shard-iclb4/
> igt@kms_content_protection@uevent.html
>   *
> https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5123/shard-iclb6/
> igt@kms_content_protection@mei_interface.html
>   *
> https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5123/shard-iclb8/
> igt@kms_content_protection@type1.html

Ram/Anshuman, Are these skips are valid on ICL Shards?
Comment 12 Anshuman Gupta 2019-08-07 08:34:24 UTC
the https://intel-gfx-ci.01.org/hardware/shard-iclb*/i915_display_info.txt logs indicates that all of these icl shards system has only eDP output, therefore these skips are valid.
Comment 13 CI Bug Log 2019-09-09 08:34:48 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@kms_content_protection@atomic - skip - No connector found with HDCP capability -}
{+ ICL fi-tgl-u re-tgl-u: igt@kms_content_protection@atomic - skip - No connector found with HDCP capability +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_362/fi-tgl-u/igt@kms_content_protection@legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_362/fi-tgl-u/igt@kms_content_protection@lic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_362/fi-tgl-u/igt@kms_content_protection@srm.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@kms_content_protection@legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@kms_content_protection@atomic-dpms.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@kms_content_protection@mei_interface.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@kms_content_protection@type1.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@kms_content_protection@uevent.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@kms_content_protection@srm.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@kms_content_protection@legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@kms_content_protection@atomic-dpms.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@kms_content_protection@mei_interface.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@kms_content_protection@type1.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@kms_content_protection@atomic.html
Comment 14 Lakshmi 2019-09-09 10:05:45 UTC
@Anshuman/Ram,

This is an expected behavior on fi-icl-u4, shard-iclb*,fi-icl-guc and icl-dsi as these are connected to either eDP panel or dsi panel but not connected HDMI/DP.

But, fi-icl-u2 and fi-icl-u3 are connected through HDMI and DP. So, this bug is valid for fi-icl-u2 and fi-icl-u3?
Comment 15 Jani Saarinen 2019-09-09 10:57:45 UTC
on u2 there is chamelium as in u4 too. So only u3 has real monitor.
Comment 16 Lakshmi 2019-09-09 12:56:55 UTC
(In reply to Lakshmi from comment #14)
> @Anshuman/Ram,
> 
> This is an expected behavior on fi-icl-u4, shard-iclb*,fi-icl-guc and
> icl-dsi as these are connected to either eDP panel or dsi panel but not
> connected HDMI/DP.
> 
> But, fi-icl-u2 and fi-icl-u3 are connected through HDMI and DP. So, this bug
> is valid for fi-icl-u2 and fi-icl-u3?

(In reply to Jani Saarinen from comment #15)
> on u2 there is chamelium as in u4 too. So only u3 has real monitor.

@Anshuman/Ram How about U3? skips are valid on u3?
Comment 17 Ramalingam C 2019-09-09 13:48:17 UTC
(In reply to Lakshmi from comment #16)
> @Anshuman/Ram How about U3? skips are valid on u3?

From https://intel-gfx-ci.01.org/hardware/fi-icl-u3/i915_display_info.txt, we can say connector 197: type DP-1 and connector 210: type HDMI-A-2 are connected to HDCP1.4 capable display panels.

Atleast we shouldn't be seeing this "No connector found with HDCP capability" for this icl-u3.

Possibily when IGT tries to read Panel is not ready with that register value, possibility due to just completed modeset. @anshuman we might want to introduce a retry for capability read!? But is it frequent issue or sporadic in nature!?
Comment 18 Lakshmi 2019-09-09 13:57:35 UTC
(In reply to Ramalingam C from comment #17)
> (In reply to Lakshmi from comment #16)
> > @Anshuman/Ram How about U3? skips are valid on u3?
> 
> From https://intel-gfx-ci.01.org/hardware/fi-icl-u3/i915_display_info.txt,
> we can say connector 197: type DP-1 and connector 210: type HDMI-A-2 are
> connected to HDCP1.4 capable display panels.
> 
> Atleast we shouldn't be seeing this "No connector found with HDCP
> capability" for this icl-u3.
> 
> Possibily when IGT tries to read Panel is not ready with that register
> value, possibility due to just completed modeset. @anshuman we might want to
> introduce a retry for capability read!? But is it frequent issue or sporadic
> in nature!?

This issue is 100% reproducible on fi-icl-u3. Here is the latest failure.
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-icl-u3/igt@kms_content_protection@content_type_change.html

So, can I create a separate issue for fi-icl-u3 and closing this issue as expected behavior as these monitor's doesn't have HDCP capable monitors?
Comment 19 CI Bug Log 2019-09-11 10:53:32 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL fi-tgl-u re-tgl-u: igt@kms_content_protection@atomic - skip - No connector found with HDCP capability -}
{+ ICL fi-tgl-u re-tgl-u: igt@kms_content_protection@atomic - skip - No connector found with HDCP capability +}


  No new failures caught with the new filter
Comment 20 CI Bug Log 2019-09-17 08:38:53 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL fi-tgl-u re-tgl-u: igt@kms_content_protection@atomic - skip - No connector found with HDCP capability -}
{+ ICL fi-tgl-u fi-tgl-u2 re-tgl-u: igt@kms_content_protection@atomic - skip - No connector found with HDCP capability +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_368/fi-tgl-u2/igt@kms_content_protection@type1.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_369/fi-tgl-u2/igt@kms_content_protection@uevent.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_369/fi-tgl-u2/igt@kms_content_protection@type1.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_369/fi-tgl-u2/igt@kms_content_protection@legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_369/fi-tgl-u2/igt@kms_content_protection@srm.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_369/fi-tgl-u2/igt@kms_content_protection@lic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_369/fi-tgl-u2/igt@kms_content_protection@atomic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_369/fi-tgl-u2/igt@kms_content_protection@atomic-dpms.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_369/fi-tgl-u2/igt@kms_content_protection@content_type_change.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_370/fi-tgl-u2/igt@kms_content_protection@uevent.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_370/fi-tgl-u2/igt@kms_content_protection@type1.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_370/fi-tgl-u2/igt@kms_content_protection@legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_370/fi-tgl-u2/igt@kms_content_protection@lic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_370/fi-tgl-u2/igt@kms_content_protection@atomic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_370/fi-tgl-u2/igt@kms_content_protection@atomic-dpms.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_370/fi-tgl-u2/igt@kms_content_protection@content_type_change.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u2/igt@kms_content_protection@srm.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u2/igt@kms_content_protection@lic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u2/igt@kms_content_protection@mei_interface.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u2/igt@kms_content_protection@legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u2/igt@kms_content_protection@atomic-dpms.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u2/igt@kms_content_protection@content_type_change.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u2/igt@kms_content_protection@atomic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u2/igt@kms_content_protection@uevent.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u2/igt@kms_content_protection@type1.html


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.