Bug 111067 - [CI][DRMTIP] igt@kms_color@pipe-b-ctm-negative - fail - Failed assertion: ret == 0, error: -22 != 0
Summary: [CI][DRMTIP] igt@kms_color@pipe-b-ctm-negative - fail - Failed assertion: ret...
Status: RESOLVED DUPLICATE of bug 111185
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-04 13:05 UTC by Lakshmi
Modified: 2019-09-23 16:32 UTC (History)
2 users (show)

See Also:
i915 platform: ICL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-07-04 13:05:53 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_320/fi-icl-u4/igt@kms_color@pipe-b-ctm-negative.html

Starting subtest: pipe-B-ctm-negative
(kms_color:1256) igt_kms-CRITICAL: Test assertion failure function igt_primary_plane_commit_legacy, file ../lib/igt_kms.c:2870:
(kms_color:1256) igt_kms-CRITICAL: Failed assertion: ret == 0
(kms_color:1256) igt_kms-CRITICAL: Last errno: 22, Invalid argument
(kms_color:1256) igt_kms-CRITICAL: error: -22 != 0
Subtest pipe-B-ctm-negative failed.
Comment 1 CI Bug Log 2019-07-04 13:07:15 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* ICL: igt@kms_color@pipe-b-ctm-negative - fail - Failed assertion: ret == 0, error: -22 != 0
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_320/fi-icl-u4/igt@kms_color@pipe-b-ctm-negative.html
Comment 2 Uma Shankar 2019-07-11 11:23:53 UTC
Synced the latest drm-tip and IGT and tried to test this IGT test. I can see there is no error while executing the kms_color@pipe-b-ctm-negative.

Can someone confirm this from CI side. If this is indeed the case, we can close this issue.
Comment 3 CI Bug Log 2019-07-22 08:40:08 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@kms_color@pipe-b-ctm-negative - fail - Failed assertion: ret == 0, error: -22 != 0 -}
{+ ICL: igt@kms_color@pipe-* - fail - Failed assertion: ret == 0, error: -22 != 0 +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_326/fi-icl-u4/igt@kms_color@pipe-c-ctm-0-5.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_327/fi-icl-u4/igt@kms_color@pipe-a-ctm-green-to-red.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_328/fi-icl-u4/igt@kms_color@pipe-a-ctm-green-to-red.html
Comment 4 Lakshmi 2019-07-22 08:41:53 UTC

(In reply to Uma Shankar from comment #2)
> Synced the latest drm-tip and IGT and tried to test this IGT test. I can see
> there is no error while executing the kms_color@pipe-b-ctm-negative.
> 
> Can someone confirm this from CI side. If this is indeed the case, we can
> close this issue.

(In reply to CI Bug Log from comment #3)
> A CI Bug Log filter associated to this bug has been updated:
> 
> {- ICL: igt@kms_color@pipe-b-ctm-negative - fail - Failed assertion: ret ==
> 0, error: -22 != 0 -}
> {+ ICL: igt@kms_color@pipe-* - fail - Failed assertion: ret == 0, error: -22
> != 0 +}
> 
> New failures caught by the filter:
> 
>   *
> https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_326/fi-icl-u4/
> igt@kms_color@pipe-c-ctm-0-5.html
>   *
> https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_327/fi-icl-u4/
> igt@kms_color@pipe-a-ctm-green-to-red.html
>   *
> https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_328/fi-icl-u4/
> igt@kms_color@pipe-a-ctm-green-to-red.html

@Uma These are new failures. Can you please comment on the latest failures?
Comment 5 CI Bug Log 2019-08-12 12:18:27 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@kms_color@pipe-* - fail - Failed assertion: ret == 0, error: -22 != 0 -}
{+ ICL: igt@kms_color@pipe-* - fail - Failed assertion: ret == 0, error: -22 != 0 +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_341/fi-icl-u4/igt@kms_color@pipe-b-ctm-green-to-red.html
Comment 6 Matt Roper 2019-09-23 16:32:49 UTC
This appears to be a duplicate of bug 111067; the failures here aren't caused by anything related to color management, but rather by a general -EINVAL returned by the encoder's compute_config() handler.

*** This bug has been marked as a duplicate of bug 111185 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.