Bug 111096 - [CI][BAT] igt@kms_chamelium@dp-hpd-fast - fail - Failed assertion: reprobe_connector(data, port) == DRM_MODE_CONNECTED
Summary: [CI][BAT] igt@kms_chamelium@dp-hpd-fast - fail - Failed assertion: reprobe_co...
Status: RESOLVED DUPLICATE of bug 111045
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: highest normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-09 14:53 UTC by Martin Peres
Modified: 2019-08-22 10:16 UTC (History)
1 user (show)

See Also:
i915 platform: ICL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-07-09 14:53:31 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6438/fi-icl-u4/igt@kms_chamelium@dp-hpd-fast.html

Starting subtest: dp-hpd-fast
(kms_chamelium:2843) CRITICAL: Test assertion failure function test_basic_hotplug, file ../tests/kms_chamelium.c:248:
(kms_chamelium:2843) CRITICAL: Failed assertion: reprobe_connector(data, port) == DRM_MODE_CONNECTED
(kms_chamelium:2843) CRITICAL: error: 2 != 1

This machine is the first one with a screen connected via USB-C, so that might explain why we never saw the issue before!
Comment 1 CI Bug Log 2019-07-09 14:54:18 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* fi-icl-u4: igt@kms_chamelium@dp-hpd-fast - fail - Failed assertion: reprobe_connector(data, port) == DRM_MODE_CONNECTED
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6438/fi-icl-u4/igt@kms_chamelium@dp-hpd-fast.html
Comment 2 emersion 2019-07-10 11:59:42 UTC

*** This bug has been marked as a duplicate of bug 111045 ***
Comment 3 CI Bug Log 2019-08-16 08:44:41 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-icl-u4: igt@kms_chamelium@dp-hpd-fast - fail - Failed assertion: reprobe_connector(data, port) == DRM_MODE_CONNECTED -}
{+ fi-icl-u4: igt@kms_chamelium@dp-hpd-fast - fail - Invalid connector status after hotplug: got disconnected, expected connected +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6713/fi-icl-u4/igt@kms_chamelium@dp-hpd-fast.html
Comment 4 CI Bug Log 2019-08-20 06:55:40 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-icl-u4: igt@kms_chamelium@dp-hpd-fast - fail - Invalid connector status after hotplug: got disconnected, expected connected -}
{+ fi-kbl-7500u fi-icl-u4: igt@kms_chamelium@(hdmi|dp)-hpd-fast - fail - Invalid connector status after hotplug: got disconnected, expected connected +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6738/fi-kbl-7500u/igt@kms_chamelium@hdmi-hpd-fast.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_347/fi-kbl-7500u/igt@kms_chamelium@hdmi-hpd-fast.html
Comment 5 CI Bug Log 2019-08-22 10:16:29 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-kbl-7500u fi-icl-u4: igt@kms_chamelium@(hdmi|dp)-hpd-fast - fail - Invalid connector status after hotplug: got disconnected, expected connected -}
{+ fi-kbl-7567u fi-kbl-7500u fi-icl-u4: igt@kms_chamelium@(hdmi|dp)-hpd-fast - fail - Invalid connector status after hotplug: got disconnected, expected connected +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_348/fi-kbl-7567u/igt@kms_chamelium@hdmi-hpd.html


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.