Bug 111149 - Intel x5-E8000 black screen on 2560x1440 monitors if DP audio is active (Kernel 4.17 - drm-tip)
Summary: Intel x5-E8000 black screen on 2560x1440 monitors if DP audio is active (Kern...
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged, ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-16 12:19 UTC by Stefan Gottwald
Modified: 2019-07-18 18:04 UTC (History)
1 user (show)

See Also:
i915 platform: BSW/CHT, BYT
i915 features: display/audio, display/DP


Attachments
logs with stock fedora kernel and drm-tip (417.13 KB, application/gzip)
2019-07-16 12:19 UTC, Stefan Gottwald
no flags Details
[PATCH] drm/i915: Make sure cdclk is high enough for DP audio on VLV/CHV (2.43 KB, patch)
2019-07-16 18:06 UTC, Ville Syrjala
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gottwald 2019-07-16 12:19:47 UTC
Created attachment 144799 [details]
logs with stock fedora kernel and drm-tip

The device with the following problem is a IGEL UD2-LX50 (internal M250C) with 2 DisplayPorts (yes one is the eDP used as normal DP but both are affected).

To Reproduce:

    * connect a 2560x1440 capable monitor (some 4k also have the same problem) like DELL P2715Q, ACER S277HK, ASUS MX27UQ, iiyama ProLite PL2792Q, Fujitsu p27-8TS Pro.... on the DP connector

    * start the system

    * the monitor will get black after pulseaudio was started (on Ubuntu after the login screen, on Fedora directly)

If pulseaudio is disabled (very quick and dirty with "sudo mv /usr/bin/pulseaudio /usr/bin/pulseaudio.real; sudo ln -sf /bin/true /usr/bin/pulseaudio") it works with the stock Fedora Kernel and with the Ubuntu default kernel. With drm-tip the screen goes directly black short after boot.

Logfiles were created with drm.debug=0x3ff kernel commandline option.

The stock-fedora-30-pulsaudio-disabled.log file shows a boot with disabled pulseaudio and working Screen with Fedora 30. In Gnome a Console was opened and pulsaudio.real started and the screen went black nearly immediately. One can grep for the pulseaudio.real start message to get in the area the error happened.

With drm-tip the error occurs with or without running pulseaudio, there were also two logfiles created. drm-tip-kernel-without-fix.log is the drm-tip from 2019-07-16 and there the screen is black shortly after boot (blinking cursor and then black). As I know how to workaround this issue I did a small change in the drm-tip kernel:

diff --git a/drivers/gpu/drm/i915/display/intel_dp.c b/drivers/gpu/drm/i915/display/intel_dp.c
index 0eb5d66f87a7..3aed538e24c2 100644
--- a/drivers/gpu/drm/i915/display/intel_dp.c
+++ b/drivers/gpu/drm/i915/display/intel_dp.c
@@ -5322,7 +5322,8 @@ intel_dp_set_edid(struct intel_dp *intel_dp)
 	edid = intel_dp_get_edid(intel_dp);
 	intel_connector->detect_edid = edid;
 
-	intel_dp->has_audio = drm_detect_monitor_audio(edid);
+	//intel_dp->has_audio = drm_detect_monitor_audio(edid);
+	intel_dp->has_audio = false;
 	drm_dp_cec_set_edid(&intel_dp->aux, edid);
 }

This only prevents the usage of DP audio, then the screen is working as one would expect (drm-tip-kernel-with-fix.log logfile).

Our own Linux is based on Ubuntu (Kernel is a 4.19.x mainline one with some fixes) and there the issue is also present, also with a Stock Ubuntu with Linux mainline or Ubuntu Kernel. We currently worked around it with a added i915 module parameter to disable DP audio support (Kernel Patch) but this is not a solution only a workaround.

If one need a device to test he could contact me and I will look if I can arrange this.
Comment 1 Ville Syrjala 2019-07-16 18:06:55 UTC
Created attachment 144804 [details] [review]
[PATCH] drm/i915: Make sure cdclk is high enough for DP audio on VLV/CHV

I was able to reproduce locally, and looks like I found the issue. Please confirm whether this fixes it for you.
Comment 2 Stefan Gottwald 2019-07-17 04:49:31 UTC
Added the Patch and tested with the iiyama ProLite PL2792Q now the screen and DP audio works. Will Test with other monitors too but I think this is the correct solution here.

Thanks for the very quick fix.
Comment 3 Ville Syrjala 2019-07-18 18:04:43 UTC
commit bffb31f73b29a60ef693842d8744950c2819851d
Author: Ville Syrjälä <ville.syrjala@linux.intel.com>
Date:   Wed Jul 17 14:45:36 2019 +0300

    drm/i915: Make sure cdclk is high enough for DP audio on VLV/CHV


Fixed. Thanks for the bug report and testing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.