Bug 111168 - [CI][DRMTIP] igt@kms_chamelium@hdmi-edid-change-during-suspend - fail - Failed assertion: igt_hotplug_detected(mon, HOTPLUG_TIMEOUT)
Summary: [CI][DRMTIP] igt@kms_chamelium@hdmi-edid-change-during-suspend - fail - Faile...
Status: RESOLVED DUPLICATE of bug 105540
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-18 16:09 UTC by Lakshmi
Modified: 2019-09-10 11:31 UTC (History)
1 user (show)

See Also:
i915 platform: ICL, KBL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-07-18 16:09:07 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_324/fi-icl-u2/igt@kms_chamelium@hdmi-edid-change-during-suspend.html


Starting subtest: hdmi-edid-change-during-suspend
(kms_chamelium:1076) CRITICAL: Test assertion failure function test_suspend_resume_edid_change, file ../tests/kms_chamelium.c:432:
(kms_chamelium:1076) CRITICAL: Failed assertion: igt_hotplug_detected(mon, HOTPLUG_TIMEOUT)
Subtest hdmi-edid-change-during-suspend failed.
**** DEBUG ****
(kms_chamelium:1076) igt_chamelium-DEBUG: Resetting the chamelium
(kms_chamelium:1076) DEBUG: Waiting for HDMI-A-2 to disconnect...
(kms_chamelium:1076) DEBUG: Reprobing HDMI-A-2...
(kms_chamelium:1076) CRITICAL: Test assertion failure function test_suspend_resume_edid_change, file ../tests/kms_chamelium.c:432:
(kms_chamelium:1076) CRITICAL: Failed assertion: igt_hotplug_detected(mon, HOTPLUG_TIMEOUT)
(kms_chamelium:1076) igt_core-INFO: Stack trace:
(kms_chamelium:1076) igt_core-INFO:   #0 ../lib/igt_core.c:1674 __igt_fail_assert()
(kms_chamelium:1076) igt_core-INFO:   #1 ../tests/kms_chamelium.c:460 test_suspend_resume_edid_change.constprop.35()
(kms_chamelium:1076) igt_core-INFO:   #2 ../tests/kms_chamelium.c:2206 __real_main2065()
(kms_chamelium:1076) igt_core-INFO:   #3 ../tests/kms_chamelium.c:2065 main()
(kms_chamelium:1076) igt_core-INFO:   #4 ../csu/libc-start.c:344 __libc_start_main()
(kms_chamelium:1076) igt_core-INFO:   #5 [_start+0x2a]
****  END  ****
Subtest hdmi-edid-change-during-suspend: FAIL (20.699s)
Comment 1 CI Bug Log 2019-07-18 16:13:51 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* fi-kbl-7500u fi-icl-u2: igt@kms_chamelium@hdmi-edid-change-during-suspend - fail - Failed assertion: igt_hotplug_detected(mon, HOTPLUG_TIMEOUT)
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_324/fi-icl-u2/igt@kms_chamelium@hdmi-edid-change-during-suspend.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_324/fi-kbl-7500u/igt@kms_chamelium@hdmi-edid-change-during-suspend.html
Comment 2 emersion 2019-07-23 12:31:54 UTC
This issue is *NOT* a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=111045, because it happens with a non-USB-C connector.

igt@kms_chamelium@hdmi-edid-change-during-suspend is always skipped, notrun or failed. This seems to be just a new failure to add to the pile.

User impact: we don't handle suspending, unplugging a monitor, replugging another one, and then resuming. But we knew that already: IIRC we don't support this feature (yet).
Comment 3 CI Bug Log 2019-08-01 13:59:57 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-kbl-7500u fi-icl-u2: igt@kms_chamelium@hdmi-edid-change-during-suspend - fail - Failed assertion: igt_hotplug_detected(mon, HOTPLUG_TIMEOUT) -}
{+ fi-kbl-7500u fi-icl-u2: igt@kms_chamelium@hdmi-edid-change-during-suspend|igt@kms_chamelium@hdmi-hpd-fast - fail - Failed assertion: igt_hotplug_detected(mon, HOTPLUG_TIMEOUT) +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5118/fi-kbl-7500u/igt@kms_chamelium@hdmi-hpd-fast.html
Comment 4 emersion 2019-08-16 13:08:05 UTC
Not sure what's up with this bug, I can't find any related failures in cibuglog.
Comment 5 emersion 2019-09-10 11:31:23 UTC

*** This bug has been marked as a duplicate of bug 105540 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.