Bug 111203 - [gen9 iris atom] Unigine Heaven gpu hang
Summary: [gen9 iris atom] Unigine Heaven gpu hang
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/Iris (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Kenneth Graunke
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2019-07-23 17:55 UTC by Mark Janes
Modified: 2019-09-25 18:47 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
card0 error from bxt HD505 (88.41 KB, text/plain)
2019-07-23 17:55 UTC, Mark Janes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2019-07-23 17:55:03 UTC
Created attachment 144859 [details]
card0 error from bxt HD505

Running unigine heaven on BXT with iris generates gpu hang after about a minute.  Bisected to:

dcfca0af7c5c2938d01abd7374b57ab242715508
Author:     Kenneth Graunke <kenneth@whitecape.org>

iris: Set XY Clipping correctly.

I was setting it based off a pipe_rasterizer_state field that appears
to be entirely dead outside of the draw module respecting it.

I should be setting it when the primitive type reaching the SF is
neither points nor lines.  This is, unfortunately, rather dirty,
as we have to look at the rasterizer state, the geometry shader state,
the tessellation evaluation shader state, and the primitive type...
Comment 1 Eero Tamminen 2019-08-29 12:42:20 UTC
(In reply to Mark Janes from comment #0)
> Running unigine heaven on BXT with iris

Moving to correct component.
Comment 2 Mark Janes 2019-09-05 16:16:55 UTC
Since Iris is not the default for 19.2, this should not block the release.  We want to keep it on the tracker, but if this is the last bug blocking the release, we will ship with it unfixed.
Comment 3 GitLab Migration User 2019-09-25 18:47:19 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1357.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.