Bug 111232 - 3200 Memory Crash My System
Summary: 3200 Memory Crash My System
Status: RESOLVED MOVED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-27 14:51 UTC by bibitocarlos
Modified: 2019-11-19 09:37 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg (869.13 KB, text/plain)
2019-07-27 14:51 UTC, bibitocarlos
no flags Details
dmesg (352.21 KB, text/x-log)
2019-09-10 12:37 UTC, bibitocarlos
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description bibitocarlos 2019-07-27 14:51:37 UTC
Created attachment 144891 [details]
dmesg

Hi,

Since 5.2 kernel, my system (raven ridge 2400G,  Asrock X470 Gaming-ITX/ac, latest bios, archlinux) crashes (black screen or green screen or flickereing screen at start). I identified the issue with my RAM's speed, which is shared between the GPU and CPU.
Everything above 2133Mhz crashes.
I dont have this issue with 5.1 kernel.
Dsmeg of the crash as attachment


Bibi
Comment 1 Alex Deucher 2019-07-29 15:58:22 UTC
Can you bisect?
Comment 2 bibitocarlos 2019-07-29 23:18:16 UTC
(In reply to Alex Deucher from comment #1)
> Can you bisect?

I'm gonna try ^^, never did it before and leave to holydays Friday.
I'm gonna start with RC, then whith commits.
You think it's a proper way ?
Comment 3 bibitocarlos 2019-09-02 01:53:24 UTC
Ok, back from holidays.
Just compiled 5.12 RC1 and it doesnt work, green screen.
Any idea which commit i should test ?
Comment 4 bibitocarlos 2019-09-08 02:02:26 UTC
I have finished bisecting.
This is the commit which created the bug : 
" Bissection : 0 révision à tester après ceci (à peu près 0 étape)
[005440066f929ba0dca8f4e0aebfbf8daac592cc] drm/amdgpu: enable gfxoff again on raven series (v2)"

What do i do next ?

Bibi
Comment 5 bibitocarlos 2019-09-08 02:09:22 UTC
Seems to be related to this bug: 
https://lore.kernel.org/lkml/624BFB8F-B586-492E-EA6-4B138DAEC831@canonical.com/T/
Comment 6 bibitocarlos 2019-09-09 01:33:56 UTC
Tried amd.iommu off but doesnt work, so it's something else.
Comment 7 bibitocarlos 2019-09-10 12:37:23 UTC
Created attachment 145321 [details]
dmesg

Tried this "amdgpu.ppfeaturemask=0xffff3fff" but iit doesnt work (from here: https://bugzilla.kernel.org/show_bug.cgi?id=204689).

Add new dmesg to check firmware version
Comment 8 bibitocarlos 2019-09-14 15:13:21 UTC
And cant revert the commit with 5.3, i get git conflict...
Comment 9 Andrey Grodzovsky 2019-09-16 18:10:24 UTC
I noticed IOMMU page fault in the log  - is disabling iommu helps ? (from grub cmdline add iommu=off)
Comment 10 bibitocarlos 2019-09-17 13:38:49 UTC
Tried with "iommu=offiommu=off amdgpu.ppfeaturemask=0xffff3fff", no change, green screen.
Comment 11 bibitocarlos 2019-10-05 12:50:14 UTC
Any idea ?
Comment 12 bibitocarlos 2019-10-30 13:17:51 UTC
Fixed with latest firmware
Comment 13 bibitocarlos 2019-11-09 17:27:12 UTC
I reopened it, it wwas not fixes with latest firmware, my bad, it was my memory which was clocked at 2133MHz by the bios...
Comment 14 Martin Peres 2019-11-19 09:37:32 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/amd/issues/879.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.