Bug 111252 - [WebGL Conformance] Intermittent test failures
Summary: [WebGL Conformance] Intermittent test failures
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-30 02:00 UTC by Mark Janes
Modified: 2019-09-25 20:34 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2019-07-30 02:00:07 UTC
Many webgl tests fail intermittently, first seen with:

156306e5e62fb4fda0e829c5798fffdf7eb1907c
Author:     Connor Abbott <cwabbott0@gmail.com>
nir/find_array_copies: Handle wildcards and overlapping copies

Tests that were seen to fail:

webgl.conformance.glsl.misc.shader-varying-packing-restrictions
webgl.deqp.functional.gles3.shaderstruct
webgl.deqp.functional.gles3.textureshadow.cube_nearest_greater
webgl.deqp.functional.gles3.textureshadow.cube_nearest_mipmap_nearest_always
webgl.deqp.functional.gles3.textureshadow.cube_nearest_never
webgl.deqp.functional.gles3.texturespecification.basic_teximage2d_2d_00
webgl.deqp.functional.gles3.texturespecification.basic_teximage2d_cube_00
webgl.deqp.functional.gles3.texturespecification.basic_teximage3d_2d_array_01
webgl.deqp.functional.gles3.texturespecification.basic_teximage3d_3d_02
webgl.deqp.functional.gles3.texturespecification.basic_teximage3d_3d_04
webgl.deqp.functional.gles3.texturespecification.basic_texsubimage2d_cube_02
webgl.deqp.functional.gles3.texturespecification.basic_texsubimage3d_03
webgl.deqp.functional.gles3.texturespecification.teximage2d_pbo_cube_03
webgl.deqp.functional.gles3.texturespecification.teximage3d_depth
webgl.deqp.functional.gles3.texturespecification.teximage3d_pbo_2d_array_00
webgl.deqp.functional.gles3.texturespecification.teximage3d_pbo_params
webgl.deqp.functional.gles3.texturespecification.texstorage2d_format_2d_00
webgl.deqp.functional.gles3.texturespecification.texstorage3d_format_2d_array_02
webgl.deqp.functional.gles3.texturespecification.texstorage3d_format_3d_03
webgl.deqp.functional.gles3.texturespecification.texstorage3d_format_size
webgl.deqp.functional.gles3.texturespecification.texsubimage2d_pbo_cube_04
webgl.deqp.functional.gles3.texturespecification.texsubimage3d_pbo_params
webgl.deqp.functional.gles3.texturewrap.eac_r11_pot
webgl.deqp.functional.gles3.texturewrap.eac_rg11_pot
webgl.deqp.functional.gles3.texturewrap.eac_signed_rg11_pot
webgl.deqp.functional.gles3.texturewrap.etc2_eac_rgba8_pot
webgl.deqp.functional.gles3.texturewrap.etc2_rgb8_pot
webgl.deqp.functional.gles3.texturewrap.etc2_srgb8_punchthrough_alpha1_pot
webgl.deqp.functional.gles3.texturewrap.rgba8_pot
webgl.deqp.functional.gles3.transformfeedback.basic_types_separate_triangles
webgl.deqp.functional.gles3.transformfeedback.point_size
webgl.deqp.functional.gles3.vertexarrays.single_attribute.output_type.unsigned_byte
webgl.deqp.functional.gles3.vertexarrays.single_attribute.usage.dynamic_draw
webgl.deqp.functional.gles3.vertexarrays.single_attribute.usage.stream_draw
Comment 1 Denis 2019-07-30 10:21:13 UTC
Hi Connor, could this list with issues have the same root cause with this bug => https://bugs.freedesktop.org/show_bug.cgi?id=111251 ?

I couldn't reproduce any failure locally, so can't test your patch.
Comment 2 GitLab Migration User 2019-09-25 20:34:04 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1823.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.