Bug 111271 - Crash in eglMakeCurrent
Summary: Crash in eglMakeCurrent
Status: RESOLVED DUPLICATE of bug 110814
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 19.1
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-31 17:49 UTC by Anthony
Modified: 2019-08-02 09:02 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Crash dump (5.80 KB, text/plain)
2019-07-31 17:49 UTC, Anthony
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anthony 2019-07-31 17:49:22 UTC
Created attachment 144920 [details]
Crash dump

Since i start using mesa 19.1 and llvm 8 i notice a crash in eglMakeCurrent (it's not happen in older 19.0 or any other)

inxi -G
Graphics:
Device-1: Intel Skylake GT2 [HD Graphics 520] driver: i915 v: kernel
Display: x11 server: X.Org 1.20.5 driver: modesetting
resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
v: 4.5 Mesa 19.1.3

Since opengl 4.5 was added in 19.1 i don't know the state of and compatibility with my skylake.
Comment 1 Sergii Romantsov 2019-08-01 09:02:02 UTC
Hello, Anthony.
Could you, please, try this patch: https://gitlab.freedesktop.org/mesa/mesa/merge_requests/1020
Comment 2 Anthony 2019-08-01 18:08:01 UTC
It works, thank. Can we have it on next release?
Comment 3 Paul 2019-08-02 09:02:34 UTC
Looks like, we have the ticket with the same issue already -  https://bugs.freedesktop.org/show_bug.cgi?id=110814 .
Issue was investigated and final fix is being discussed for now.
Also, I've suggested to add  this issue to the release tracker.

*** This bug has been marked as a duplicate of bug 110814 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.