Bug 111285 - [psr] Unable to boot after update to 5.2.1 kernel (Skylake)
Summary: [psr] Unable to boot after update to 5.2.1 kernel (Skylake)
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Jose Roberto de Souza
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev, Triaged
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-02 13:00 UTC by Mikael Widersten
Modified: 2019-08-09 17:10 UTC (History)
3 users (show)

See Also:
i915 platform: SKL
i915 features: display/PSR


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikael Widersten 2019-08-02 13:00:36 UTC
Lenovo X1 Skylake GT2 520 rev 7, i915 driver; openSUSE Tumbleweed 190730, plasma 5.16.3, Qt 5.13.0, kernel-default 5.1.16-1

Booting into sddm fails following update from 5.1.16 to 5.2.1 (distribution provided kernel). I have tried up to 5.2.4 and the problem persists. It is impossible to boot without an attached external screen (via DP). After booting, interacting through the external screen, the system behaves normal (but with an unusable internal screen - it is frozen). Reverting back to 5.1.6 fixed the issue.

With kernel 5.2.3 booting reaches all the way to sddm but screen is frozen and unresponsive.

best,

/mikael
Comment 1 Chris Wilson 2019-08-02 13:03:37 UTC
Quick test is to add i915.enable_psr=0 to the kernel commandline (grub)
Comment 2 Mikael Widersten 2019-08-02 14:08:01 UTC
Indeed, i915.enable_psr=0 cured the problem.

Thanks,

/mikael
Comment 3 Chris Wilson 2019-08-02 14:13:30 UTC
José any suggestion on which patches to test, or is everything queued up for stable by this point?
Comment 4 Jose Roberto de Souza 2019-08-02 17:11:22 UTC
Hi Mikael

If you want you can compile your own kernel with this fix: https://patchwork.freedesktop.org/series/63774/#rev4

Otherwise keep i915.enable_psr=0 as Chris said until that patch gets to kernel stable, the last updated that I got is that it would be included on Linux 5.2.6 to be released in this coming week.
Comment 5 Mikael Widersten 2019-08-02 17:32:59 UTC
Thanks, I'll wait for 5.2.6.

cheers,

/mikael
Comment 6 Mikael Widersten 2019-08-06 10:30:50 UTC
I tried the 5.2.6 kernel from the openSUSE stable repository (kernel-default-5.2.6-1.1.g187170c)  and changed to i915.enable_psr=2. Problem still there. 
Went back to 5.2.3 and changed back to i915.enable_psr=0 for a working system.
Comment 7 Jose Roberto de Souza 2019-08-06 18:58:30 UTC
Hi Mikael

The fix was not included on 5.2.6, hopefully it will on 5.2.7 as Greg asked the backported version.
Comment 8 Takashi Iwai 2019-08-07 13:44:12 UTC
Apparently 5.2.7 doesn't seem solving the problem, according to openSUSE bugzilla entry:
https://bugzilla.opensuse.org/show_bug.cgi?id=1143139#c30

> Martin Wilck 2019-08-07 13:32:47 UTC
>
> I have the same problem as in bug 1143755. It is *not* solved in 5.2.7-1.ga3e04b1 (the workaround "i915.enable_psr=0" helps), but it is solved in 5.3.rc3-1.1.g571863b. I have Skylake hardware:
>
> > $ cat /sys/kernel/debug/dri/0/i915_capabilities
> > gen: 9
> > platform: SKYLAKE
> > pch: 4
> > is_mobile: no
> > ...
> > has_psr: yes
>
> I've tried to figure out the relevant commit but I haven't yet. Note that 5.3-rc3 does not include the patch which disables PSR2 ( https://patchwork.freedesktop.org/patch/319173/?series=63774&rev=4).
>
> > $ git log --oneline --grep PSR -i v5.2..v5.3-rc3 -- drivers/gpu/drm/i915/
> > 6d61f71 drm/i915/vbt: Fix VBT parsing for the PSR section
> > 417f254 Merge tag 'drm-intel-next-2019-06-19' of git://anongit.freedesktop.org/drm/drm-intel into drm-next
> > 381f8a2 drm/i915/psr: Force manual PSR exit in older gens
> > 4d432f95 drm: Rename struct edp_vsc_psr to struct dp_sdp
> > 8e9d645 drm/i915/dp: Add a config function for YCBCR420 outputs
> > 6f08ebe drm/i915: Remove the unneeded AUX power ref from intel_dp_hpd_pulse()
>
> I suspected 381f8a2 but that makes little sense as that affects gen < 9 only, and I have gen = 9. So the only one that remains would be 6d61f71, no idea if that makes sense.
Comment 9 Jose Roberto de Souza 2019-08-07 17:25:07 UTC
We sent the backport of "drm/i915/vbt: Fix VBT parsing for the PSR section" to Greg but it did not made to 5.2.7.
Comment 10 Takashi Iwai 2019-08-09 09:59:18 UTC
I backported the patch into openSUSE kernel, and it was confirmed to work.  Thanks.
Comment 11 Jose Roberto de Souza 2019-08-09 17:10:24 UTC
Fix merged on Linux 5.2.8


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.