Bug 111293 - [chv][regression][bisected] Brightness adjustment on Lenovo Miix 320-10ICR and Lenovo Miix2 8 is broken since Linux 5.3rc1
Summary: [chv][regression][bisected] Brightness adjustment on Lenovo Miix 320-10ICR an...
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-03 11:02 UTC by russianneuromancer
Modified: 2019-08-19 15:00 UTC (History)
3 users (show)

See Also:
i915 platform: BSW/CHT
i915 features: display/backlight


Attachments
drm-tip dmesg with drm.debug=0x1e from Lenovo Miix 320-10ICR (316.76 KB, text/plain)
2019-08-03 11:02 UTC, russianneuromancer
no flags Details
drm-tip dmesg with drm.debug=0x1e from Lenovo Miix2 8 (202.15 KB, text/plain)
2019-08-06 16:52 UTC, russianneuromancer
no flags Details
Linux 5.2.7 dmesg with drm.debug=0x1e from Lenovo Miix 320-10ICR (383.20 KB, text/plain)
2019-08-07 14:49 UTC, russianneuromancer
no flags Details
Linux 5.2.7 dmesg with drm.debug=0x1e from Lenovo Miix2 8 (222.52 KB, text/plain)
2019-08-07 14:49 UTC, russianneuromancer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description russianneuromancer 2019-08-03 11:02:30 UTC
Created attachment 144941 [details]
drm-tip dmesg with drm.debug=0x1e from Lenovo Miix 320-10ICR

Hello!

I find that brightness adjustment is broken on Lenovo Miix 320-10ICR since Linux 5.3rc1, git bisect lead to this commit:

https://github.com/torvalds/linux/commit/4a6ef8e37c4d9a40f09438068da1734fd965bd75

drm-tip 2019-07-30 4040b4c4ab647422d82100c8b091d34b6a82f572 log with drm.debug=0x1e log_buf_len=8M where I trying to adjust brightness is attached.

Brightness adjustment works fine on Linux 5.0-5.2 (earlies releases wasn't tested).
Comment 1 Chris Wilson 2019-08-03 11:40:11 UTC
You should definitely mention what interface you are using to change the backlight.
Comment 2 russianneuromancer 2019-08-03 13:13:45 UTC
On Linux 5.0-5.2 I adjusted backlight via Gnome Shell slider in upper right corner. On Linux 5.3rc1+ this is no longer works, according to git bisect this is due to mentioned commit. That all I know right now.

If I can provide more data from working/mom-working kernel - please let me know how to do so.
Comment 3 Lakshmi 2019-08-06 08:11:39 UTC
[7.984343] [drm:intel_panel_vbt_fixed_mode [i915]] [CONNECTOR:105:DSI-1] using mode from VBT: 
[    7.984387] [drm:drm_mode_debug_printmodeline [drm]] Modeline "1200x1920": 0 162980 1200 1280 1284 1344 1920 1980 1981 2021 0x8 0xa
[    7.984494] [drm:pwm_setup_backlight [i915]] *ERROR* Failed to own the pwm chip
[    7.984600] [drm:intel_panel_setup_backlight [i915]] failed to setup backlight for connector DSI-1
[    7.984698] [drm:intel_dsi_get_hw_state [i915]] 
[    7.984922] [drm:intel_modeset_readout_hw_state [i915]] [CRTC:47:pipe A] hw state readout: enabled

@Chris, any suggestion here? Does this error give any clue?
Comment 4 Chris Wilson 2019-08-06 08:14:50 UTC
Two drivers for one bit of backlight HW, doomed to fail.

If the acpi driver exposed a /sys/class/backlight, xf86-video-intel should have still found it.
Comment 5 russianneuromancer 2019-08-06 16:52:11 UTC
Created attachment 144959 [details]
drm-tip dmesg with drm.debug=0x1e from Lenovo Miix2 8

As I just found same issue is reproducible on Lenovo Miix2 8 too.

Attached log is from drm-tip 2019-08-05 (2bb7df95d4e058e61d9de39f1b97404592708d24)

> If the acpi driver exposed a /sys/class/backlight, xf86-video-intel should have still found it.

Lenovo Miix2 8, Lenovo Miix 320-10IRC
On Linux 5.2 there is just one intel_backlight, adjusting brightness via intel_backlight works.

Lenovo Miix2 8:
On Linux 5.3 there is acpi_video0 and acpi_video1, echo values to brightness file in each one doesn't change backlight level.

Lenovo Miix 320-10IRC:
On Linux 5.3 there is...

~# ls /sys/class/backlight
acpi_video0  acpi_video1  acpi_video2  acpi_video3  acpi_video4  acpi_video5  acpi_video6  acpi_video7

As with Lenovo Miix2 8, echo values to brightness file in each acpi_video doesn't change backlight level.
Comment 6 russianneuromancer 2019-08-07 14:48:46 UTC
For comparison below is logs from Linux 5.2.7 with drm.debug=0x1e and working backlight adjustment:
Comment 7 russianneuromancer 2019-08-07 14:49:13 UTC
Created attachment 144972 [details]
Linux 5.2.7 dmesg with drm.debug=0x1e from Lenovo Miix 320-10ICR
Comment 8 russianneuromancer 2019-08-07 14:49:24 UTC
Created attachment 144973 [details]
Linux 5.2.7 dmesg with drm.debug=0x1e from Lenovo Miix2 8
Comment 9 Jani Nikula 2019-08-08 07:30:42 UTC
Cc Thierry, committer of the regressing commit

commit 4a6ef8e37c4d9a40f09438068da1734fd965bd75
Author: Nikolaus Voss <nikolaus.voss@loewensteinmedical.de>
Date:   Wed Jun 12 10:36:07 2019 +0200

    pwm: Add support referencing PWMs from ACPI

Any thoughts?
Comment 10 Jani Nikula 2019-08-09 08:07:15 UTC
Per Thierry, the fix is [1], on its way to v5.3-rc4. Thanks for the report, closing. Please reopen if the problem persists with that commit.

[1] https://kernel.googlesource.com/pub/scm/linux/kernel/git/thierry.reding/linux-pwm/+/6cf9481b440da6d6d86bd8e4c99a8b553b9d1271
Comment 11 russianneuromancer 2019-08-19 15:00:01 UTC
Issue is no longer reproducible with Linux 5.3rc4.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.