Bug 111297 - xorg hangs at boot only with vesa driver and quiet kernel parameter
Summary: xorg hangs at boot only with vesa driver and quiet kernel parameter
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-05 11:56 UTC by Carlos
Modified: 2019-10-10 21:58 UTC (History)
1 user (show)

See Also:
i915 platform: ILK
i915 features: display/Other


Attachments
dmesg output (21.70 KB, application/x-bzip)
2019-08-05 11:56 UTC, Carlos
no flags Details
dmesg with 5.3.0-rc3+ (14.44 KB, application/x-bzip)
2019-08-11 10:07 UTC, Carlos
no flags Details
dmesg_kernel_debug_log_buf parameters (62.44 KB, application/x-bzip)
2019-08-13 19:55 UTC, Carlos
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos 2019-08-05 11:56:08 UTC
Created attachment 144949 [details]
dmesg output

lspci -v 

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
        Subsystem: Lenovo Core Processor Integrated Graphics Controller
        Flags: bus master, fast devsel, latency 0, IRQ 32
        Memory at f2000000 (64-bit, non-prefetchable) [size=4M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 1800 [size=8]
        [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915

Model name: Intel(R) Core(TM) i5 CPU       M 520  @ 2.40GHz



This started with 5.2 and still goes on with 5.2.5

If the 'quiet' kernel parameter is omitted, the system starts normally. 

If it's not omitted, then it's a hard hang, and X wouldn't start.

It also works fine after a wakeup by suspending the system.

Disabling wireless connection from the bios made no difference. Only enabling log messages on the kernel parameter does. 

Also, video-intel seems not affected by this.
Comment 1 Chris Wilson 2019-08-05 12:06:15 UTC
[    5.995550] ------------[ cut here ]------------
[    5.995558] WARN_ON((val & ((u32)((((~0UL) - (1UL << (16)) + 1) & (~0UL >> (64 - 1 - (31)))) + (sizeof(struct { int:(-!!(__builtin_constant_p(31) && __builtin_constant_p(16) && ((16) < 0 || (31) > 31 || (16) > (31)))); }))))) != ((u32)((((typeof(((u32)((((~0UL) - (1UL << (16)) + 1) & (~0UL >> (64 - 1 - (31)))) + (sizeof(struct { int:(-!!(__builtin_constant_p(3
1) && __builtin_constant_p(16) && ((16) < 0 || (31) > 31 || (16) > (31)))); }))))))(0xabcd) << (__builtin_ffsll(((u32)((((~0UL) - (1UL << (16)) + 1) & (~0UL >> (64 - 1 - (31)))) + (sizeof(struct { int:(-!!(__builtin_constant_p(31) && __builtin_constant_p(16) && ((16) < 0 || (31) > 31 || (16) > (31)))); }))))) - 1)) & (((u32)((((~0UL) - (1UL << (16)) + 1) & (~0UL 
>> (64 - 1 - (31)))) + (sizeof(struct { int:(-!!(__builtin_constant_p(31) && __builtin_constant_p(16) && ((16) < 0 || (31) > 31 || (16) > (31)))); })))))) + (sizeof(struct { int:(-!!(!(sizeof(int) == sizeof(*(8 ? ((void *)((long)(((u32)((((~0UL) - (1UL << (16)) + 1) & (~0UL >
[    5.995661] WARNING: CPU: 2 PID: 41 at drivers/gpu/drm/i915/intel_lvds.c:205 intel_pre_enable_lvds+0x284/0x290 [i915]
[    5.995662] Modules linked in: intel_powerclamp coretemp kvm_intel arc4 kvm snd_hda_codec_hdmi snd_hda_codec_conexant snd_hda_codec_generic iwldvm mac80211 irqbypass iwlwifi crct10dif_pclmul crc32_pclmul ghash_clmulni_intel mei_wdt i915 iTCO_wdt iTCO_vendor_support i2c_algo_bit uvcvideo drm_kms_helper videobuf2_vmalloc videobuf2_memops btusb videobuf2_v4l2 vid
eobuf2_common btrtl btbcm btintel aesni_intel wmi_bmof mxm_wmi snd_hda_intel snd_hda_codec aes_x86_64 bluetooth drm crypto_simd cfg80211 videodev qcserial snd_hda_core usb_wwan cryptd snd_hwdep glue_helper snd_pcm psmouse intel_cstate joydev mousedev intel_uncore e1000e media snd_timer ecdh_generic pcspkr input_leds ecc thinkpad_acpi intel_agp mei_me nvram intel_
gtt syscopyarea sysfillrect ledtrig_audio agpgart sysimgblt mei fb_sys_fops i2c_i801 snd rfkill lpc_ich intel_ips soundcore battery ac evdev mac_hid wmi pcc_cpufreq acpi_cpufreq ip_tables x_tables ext4 crc32c_generic crc16 mbcache jbd2 sr_mod cdrom sd_mod hid_logitech_hidpp
[    5.995704]  hid_logitech_dj hid_generic usbhid hid serio_raw atkbd libps2 ahci libahci libata sdhci_pci crc32c_intel cqhci scsi_mod firewire_ohci sdhci firewire_core mmc_core ehci_pci ehci_hcd crc_itu_t i8042 serio
[    5.995717] CPU: 2 PID: 41 Comm: kworker/2:1 Not tainted 5.2.2-arch1-1-ARCH #1
[    5.995718] Hardware name: LENOVO 2539A58/2539A58, BIOS 6IET74WW (1.34 ) 10/25/2010
[    5.995735] Workqueue: events output_poll_execute [drm_kms_helper]
[    5.995766] RIP: 0010:intel_pre_enable_lvds+0x284/0x290 [i915]
[    5.995768] Code: 00 00 02 e9 6a ff ff ff 81 e2 ff ff ff fd e9 5f ff ff ff 48 c7 c6 d8 03 eb c0 48 c7 c7 34 34 ec c0 89 54 24 04 e8 fb ce 65 f9 <0f> 0b 8b 54 24 04 e9 f6 fd ff ff 90 66 66 66 66 90 41 56 49 89 d6
[    5.995769] RSP: 0018:ffff8f9f407c7af0 EFLAGS: 00010286
[    5.995770] RAX: 0000000000000000 RBX: ffff8a4822850000 RCX: 0000000000000000
[    5.995771] RDX: 0000000000000007 RSI: ffffffffbbc9f7df RDI: 0000000000000246
[    5.995771] RBP: ffff8a4830f9aa00 R08: 00000001655cf59e R09: 00000000000003df
[    5.995772] R10: ffffffffbbc9f7e0 R11: ffffffffbbc9f3ff R12: ffff8a4826965000
[    5.995773] R13: 0000000000000000 R14: ffff8a4822850748 R15: ffff8a4822850000
[    5.995774] FS:  0000000000000000(0000) GS:ffff8a4833d00000(0000) knlGS:0000000000000000
[    5.995775] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    5.995777] CR2: 00007fc784ed2600 CR3: 000000006ae0a004 CR4: 00000000000206e0
[    5.995777] Call Trace:
[    5.995813]  intel_encoders_pre_enable.isra.0+0x65/0x80 [i915]
[    5.995844]  ironlake_crtc_enable+0x194/0xc50 [i915]
[    5.995875]  intel_update_crtc+0x5c/0x370 [i915]
[    5.995905]  intel_update_crtcs+0x4e/0x70 [i915]
[    5.995935]  intel_atomic_commit_tail+0x3a5/0x1310 [i915]
[    5.995967]  intel_atomic_commit+0x275/0x2b0 [i915]
[    5.995975]  restore_fbdev_mode_atomic+0x1e1/0x200 [drm_kms_helper]
[    5.995982]  drm_fb_helper_restore_fbdev_mode_unlocked+0x49/0xa0 [drm_kms_helper]
[    5.995989]  drm_fb_helper_set_par+0x2c/0x50 [drm_kms_helper]
[    5.995995]  drm_fb_helper_hotplug_event.part.0+0x92/0xb0 [drm_kms_helper]
[    5.996001]  drm_kms_helper_hotplug_event+0x26/0x30 [drm_kms_helper]
[    5.996007]  output_poll_execute+0x1ac/0x1d0 [drm_kms_helper]
[    5.996011]  process_one_work+0x1d1/0x3e0
[    5.996013]  worker_thread+0x4a/0x3d0
[    5.996016]  kthread+0xfb/0x130
[    5.996017]  ? process_one_work+0x3e0/0x3e0
[    5.996019]  ? kthread_park+0x90/0x90
[    5.996023]  ret_from_fork+0x35/0x40
[    5.996026] ---[ end trace f0936d9d4bd6878e ]---
[    6.248715] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[    6.249477] [drm:ironlake_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
[    6.265014] [drm:pipe_config_err [i915]] *ERROR* mismatch in pch_pfit.enabled (expected no, found yes)
[    6.265020] ------------[ cut here ]------------
[    6.265021] pipe state doesn't match!
[    6.265101] WARNING: CPU: 2 PID: 41 at drivers/gpu/drm/i915/intel_display.c:12697 intel_atomic_commit_tail+0x129c/0x1310 [i915]
[    6.265102] Modules linked in: intel_powerclamp coretemp kvm_intel arc4 kvm snd_hda_codec_hdmi snd_hda_codec_conexant snd_hda_codec_generic iwldvm mac80211 irqbypass iwlwifi crct10dif_pclmul crc32_pclmul ghash_clmulni_intel mei_wdt i915 iTCO_wdt iTCO_vendor_support i2c_algo_bit uvcvideo drm_kms_helper videobuf2_vmalloc videobuf2_memops btusb videobuf2_v4l2 videobuf2_common btrtl btbcm btintel aesni_intel wmi_bmof mxm_wmi snd_hda_intel snd_hda_codec aes_x86_64 bluetooth drm crypto_simd cfg80211 videodev qcserial snd_hda_core usb_wwan cryptd snd_hwdep glue_helper snd_pcm psmouse intel_cstate joydev mousedev intel_uncore e1000e media snd_timer ecdh_generic pcspkr input_leds ecc thinkpad_acpi intel_agp mei_me nvram intel_gtt syscopyarea sysfillrect ledtrig_audio agpgart sysimgblt mei fb_sys_fops i2c_i801 snd rfkill lpc_ich intel_ips soundcore battery ac evdev mac_hid wmi pcc_cpufreq acpi_cpufreq ip_tables x_tables ext4 crc32c_generic crc16 mbcache jbd2 sr_mod cdrom sd_mod hid_logitech_hidpp
[    6.265158]  hid_logitech_dj hid_generic usbhid hid serio_raw atkbd libps2 ahci libahci libata sdhci_pci crc32c_intel cqhci scsi_mod firewire_ohci sdhci firewire_core mmc_core ehci_pci ehci_hcd crc_itu_t i8042 serio
[    6.265176] CPU: 2 PID: 41 Comm: kworker/2:1 Tainted: G        W         5.2.2-arch1-1-ARCH #1
[    6.265178] Hardware name: LENOVO 2539A58/2539A58, BIOS 6IET74WW (1.34 ) 10/25/2010
[    6.265194] Workqueue: events output_poll_execute [drm_kms_helper]
[    6.265245] RIP: 0010:intel_atomic_commit_tail+0x129c/0x1310 [i915]
[    6.265248] Code: 41 8b b7 90 04 00 00 ba 01 00 00 00 4c 89 e7 e8 aa 45 01 00 e9 87 f7 ff ff e8 1f 43 6a f9 0f 0b e9 d6 fc ff ff e8 13 43 6a f9 <0f> 0b e9 85 f5 ff ff e8 07 43 6a f9 0f 0b 0f b6 04 24 e9 a8 f4 ff
[    6.265249] RSP: 0018:ffff8f9f407c7c38 EFLAGS: 00010282
[    6.265251] RAX: 0000000000000000 RBX: ffff8a4826965000 RCX: 0000000000000000
[    6.265253] RDX: 0000000000000007 RSI: 0000000000000082 RDI: 00000000ffffffff
[    6.265254] RBP: ffff8a4822850000 R08: 00000000000003b6 R09: 0000000000000001
[    6.265255] R10: 0000000000000000 R11: 0000000000000001 R12: ffff8a48228502b0
[    6.265257] R13: ffff8a48284a4800 R14: ffff8a48228502b8 R15: ffff8a4830cb4000
[    6.265259] FS:  0000000000000000(0000) GS:ffff8a4833d00000(0000) knlGS:0000000000000000
[    6.265260] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    6.265262] CR2: 00005584b70ae000 CR3: 000000006ae0a005 CR4: 00000000000206e0
[    6.265263] Call Trace:
[    6.265321]  intel_atomic_commit+0x275/0x2b0 [i915]
[    6.265333]  restore_fbdev_mode_atomic+0x1e1/0x200 [drm_kms_helper]
[    6.265346]  drm_fb_helper_restore_fbdev_mode_unlocked+0x49/0xa0 [drm_kms_helper]
[    6.265356]  drm_fb_helper_set_par+0x2c/0x50 [drm_kms_helper]
[    6.265366]  drm_fb_helper_hotplug_event.part.0+0x92/0xb0 [drm_kms_helper]
[    6.265376]  drm_kms_helper_hotplug_event+0x26/0x30 [drm_kms_helper]
[    6.265386]  output_poll_execute+0x1ac/0x1d0 [drm_kms_helper]
[    6.265392]  process_one_work+0x1d1/0x3e0
[    6.265395]  worker_thread+0x4a/0x3d0
[    6.265399]  kthread+0xfb/0x130
[    6.265402]  ? process_one_work+0x3e0/0x3e0
[    6.265404]  ? kthread_park+0x90/0x90
[    6.265409]  ret_from_fork+0x35/0x40
[    6.265414] ---[ end trace f0936d9d4bd6878f ]---
Comment 2 Lakshmi 2019-08-08 11:14:02 UTC
(In reply to Carlos from comment #0)
> Created attachment 144949 [details]
> dmesg output
> 
> lspci -v 
> 
> 00:02.0 VGA compatible controller: Intel Corporation Core Processor
> Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
>         Subsystem: Lenovo Core Processor Integrated Graphics Controller
>         Flags: bus master, fast devsel, latency 0, IRQ 32
>         Memory at f2000000 (64-bit, non-prefetchable) [size=4M]
>         Memory at d0000000 (64-bit, prefetchable) [size=256M]
>         I/O ports at 1800 [size=8]
>         [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
>         Capabilities: <access denied>
>         Kernel driver in use: i915
>         Kernel modules: i915
> 
> Model name: Intel(R) Core(TM) i5 CPU       M 520  @ 2.40GHz
> 
> 
> 
> This started with 5.2 and still goes on with 5.2.5
> 
> If the 'quiet' kernel parameter is omitted, the system starts normally. 
> 
> If it's not omitted, then it's a hard hang, and X wouldn't start.
> 
> It also works fine after a wakeup by suspending the system.
> 
> Disabling wireless connection from the bios made no difference. Only
> enabling log messages on the kernel parameter does. 
> 
> Also, video-intel seems not affected by this.
Can you verify the issue with drmtip (https://cgit.freedesktop.org/drm-tip)?
Logs from drmtip would be helpful during investigation.
Comment 3 Carlos 2019-08-11 10:07:17 UTC
Created attachment 145021 [details]
dmesg with 5.3.0-rc3+
Comment 4 Carlos 2019-08-11 10:21:54 UTC
> Can you verify the issue with drmtip (https://cgit.freedesktop.org/drm-tip)?
> Logs from drmtip would be helpful during investigation.

I can't verify it with drm-tip now, see the log attached above for 5.3.0-rc3+

But this problem persists there for me even with a recent 5.2.8 release. 

In all honesty,  I don't know what to make out of  it and where the cause - the real cause may lie - at least for this use case. It started, as I said earlier with 5.2 and considering is not a major breaker for this system for which I'm reporting it under, omitting the 'quiet' parameter is thus a quick solution. Considering that without it - and hence not omitting it - the system would have to be suspended/hibernated which a wakeup would resume normal functioning... and this would be much less preferable/convenient.
Comment 5 Lakshmi 2019-08-13 07:13:09 UTC
(In reply to Carlos from comment #3)
> Created attachment 145021 [details]
> dmesg with 5.3.0-rc3+

Can you please attach the dmesg from boot with kernel parameters drm.debug=0x1e log_buf_len=4M. This way we know more details.
Comment 6 Carlos 2019-08-13 19:55:47 UTC
Created attachment 145048 [details]
dmesg_kernel_debug_log_buf parameters

> Can you please attach the dmesg from boot with kernel parameters drm.debug=0x1e > log_buf_len=4M. This way we know more details.

Done. See attachment.
Comment 7 Carlos 2019-08-13 20:02:36 UTC
What I found odd - so to speak - was that with drm-tip, even a 'quiet' parameter would have no further effects. It's as 'good' as not having it in the first place.
Comment 8 Lakshmi 2019-10-02 18:17:02 UTC
(In reply to Carlos from comment #7)
> What I found odd - so to speak - was that with drm-tip, even a 'quiet'
> parameter would have no further effects. It's as 'good' as not having it in
> the first place.

If this WORKSFORYOU, Can we close this bug?
Comment 9 Carlos 2019-10-10 05:51:42 UTC
> If this WORKSFORYOU, Can we close this bug?

Yes Lakshmi, you can close it. Sorry for the late reply though.
Comment 10 Lakshmi 2019-10-10 11:23:42 UTC
(In reply to Carlos from comment #9)
> > If this WORKSFORYOU, Can we close this bug?
> 
> Yes Lakshmi, you can close it. Sorry for the late reply though.

Thanks!
Comment 11 Carlos 2019-10-10 21:23:45 UTC
(In reply to Lakshmi from comment #10)
> (In reply to Carlos from comment #9)
> > > If this WORKSFORYOU, Can we close this bug?
> > 
> > Yes Lakshmi, you can close it. Sorry for the late reply though.
> 
> Thanks!

Lakshmi, mmm... I lost track of drm-tip development, but somehow the issue got fixed with xf86-video-intel... Now with the quiet parameter, the system does not hang... 

Thanks!
Comment 12 Carlos 2019-10-10 21:58:25 UTC
Lakshmi, let me clarify that with xf86-video-vesa it should be marked - as you said - as WORKSFORME. Thanks again.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.