Bug 111326 - [CI][SHARDS] igt@i915_query@engine-info - fail - Failed assertion: gem_has_bsd2(fd)
Summary: [CI][SHARDS] igt@i915_query@engine-info - fail - Failed assertion: gem_has_bs...
Status: RESOLVED DUPLICATE of bug 111311
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: high normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-08 07:59 UTC by Lakshmi
Modified: 2019-08-08 08:55 UTC (History)
1 user (show)

See Also:
i915 platform: ICL
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-08-08 07:59:20 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6646/shard-iclb2/igt@i915_query@engine-info.html
Starting subtest: engine-info
(i915_query:1397) CRITICAL: Test assertion failure function engines, file ../tests/i915/i915_query.c:694:
(i915_query:1397) CRITICAL: Failed assertion: gem_has_bsd2(fd)
Subtest engine-info failed.
**** DEBUG ****
(i915_query:1397) DEBUG: 0: class=0 instance=0 flags=0 capabilities=0
(i915_query:1397) DEBUG: 1: class=1 instance=0 flags=0 capabilities=0
(i915_query:1397) DEBUG: 2: class=2 instance=0 flags=0 capabilities=3
(i915_query:1397) DEBUG: 3: class=2 instance=1 flags=0 capabilities=1
(i915_query:1397) CRITICAL: Test assertion failure function engines, file ../tests/i915/i915_query.c:694:
(i915_query:1397) CRITICAL: Failed assertion: gem_has_bsd2(fd)
(i915_query:1397) igt_core-INFO: Stack trace:
(i915_query:1397) igt_core-INFO:   #0 ../lib/igt_core.c:1674 __igt_fail_assert()
(i915_query:1397) igt_core-INFO:   #1 ../tests/i915/i915_query.c:691 __real_main721()
(i915_query:1397) igt_core-INFO:   #2 ../tests/i915/i915_query.c:721 main()
(i915_query:1397) igt_core-INFO:   #3 ../csu/libc-start.c:344 __libc_start_main()
(i915_query:1397) igt_core-INFO:   #4 [_start+0x2a]
****  END  ****
Subtest engine-info: FAIL (0.004s)
Comment 2 Chris Wilson 2019-08-08 08:03:43 UTC
Yup, we told userspace we have 2 VCS engines (0, 1) but stuck the second engine in the VCS2 slot (not the VCS1 slot as expected by the legacy api).
Comment 3 Chris Wilson 2019-08-08 08:55:46 UTC

*** This bug has been marked as a duplicate of bug 111311 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.