Bug 111338 - [CI][BAT] igt@i915_module_load@reload-no-display - incomplete - BUG: kernel NULL pointer dereference
Summary: [CI][BAT] igt@i915_module_load@reload-no-display - incomplete - BUG: kernel N...
Status: RESOLVED DUPLICATE of bug 111320
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: highest normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-09 11:00 UTC by Lakshmi
Modified: 2019-08-09 11:24 UTC (History)
1 user (show)

See Also:
i915 platform: CFL
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-08-09 11:00:43 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6658/fi-whl-u/igt@i915_module_load@reload-no-display.html

	
<6> [267.250547] Console: switching to colour dummy device 80x25
<6> [267.250632] [IGT] i915_module_load: executing
<6> [267.255361] [IGT] i915_module_load: starting subtest reload-no-display
<7> [267.312976] [drm:intel_power_well_enable [i915]] enabling power well 2
<7> [267.320146] [drm:i915_audio_component_get_eld [i915]] Not valid for port B
<7> [267.320203] [drm:i915_audio_component_get_eld [i915]] Not valid for port B
<7> [267.320247] [drm:i915_audio_component_get_eld [i915]] Not valid for port B
<7> [267.320289] [drm:i915_audio_component_get_eld [i915]] Not valid for port C
<7> [267.320329] [drm:i915_audio_component_get_eld [i915]] Not valid for port C
<7> [267.320368] [drm:i915_audio_component_get_eld [i915]] Not valid for port C
<7> [267.320408] [drm:i915_audio_component_get_eld [i915]] Not valid for port D
<7> [267.320447] [drm:i915_audio_component_get_eld [i915]] Not valid for port D
<7> [267.320491] [drm:i915_audio_component_get_eld [i915]] Not valid for port D
<1> [267.320670] BUG: kernel NULL pointer dereference, address: 0000000000000629
<1> [267.320681] #PF: supervisor read access in kernel mode
<1> [267.320687] #PF: error_code(0x0000) - not-present page
<6> [267.320694] PGD 0 P4D 0 
<4> [267.320699] Oops: 0000 [#1] PREEMPT SMP NOPTI
<4> [267.320706] CPU: 0 PID: 266 Comm: kworker/0:2 Tainted: G     U            5.3.0-rc3-CI-CI_DRM_6658+ #1
<4> [267.320715] Hardware name: Intel Corporation CoffeeLake Client Platform/WhiskeyLake U DDR4 ERB, BIOS CNLSFWR1.R00.X137.B00.1803280218 03/28/2018
<4> [267.320732] Workqueue: events snd_hdac_bus_process_unsol_events [snd_hda_core]
<4> [267.320743] RIP: 0010:hdmi_unsol_event+0x7/0x120 [snd_hda_codec_hdmi]
<4> [267.320751] Code: 0f b7 d6 48 c7 c6 a0 b0 05 a0 5d 41 5c 41 5d e9 81 26 63 e1 0f 1f 44 00 00 66 2e 0f 1f 84 00 00 00 00 00 48 8b 87 48 06 00 00 <80> b8 29 06 00 00 00 74 02 f3 c3 41 54 41 89 f4 55 53 41 c1 ec 1a
<4> [267.320768] RSP: 0018:ffffc9000177fe50 EFLAGS: 00010286
<4> [267.320775] RAX: 0000000000000000 RBX: ffff888445a65998 RCX: 0000000000000004
<4> [267.320782] RDX: ffffffffa013f050 RSI: 00000000ffffffff RDI: ffff888443c08008
<4> [267.320790] RBP: ffffc9000177fec8 R08: 0000000000000000 R09: 0000000000000001
<4> [267.320797] R10: 00000000ec06d5d7 R11: 00000000b6cf1b9f R12: ffff88845b839900
<4> [267.320805] R13: ffff88845b83dc00 R14: 0000000000000000 R15: 0000000000000001
<4> [267.320812] FS:  0000000000000000(0000) GS:ffff88845b800000(0000) knlGS:0000000000000000
<4> [267.320822] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
<4> [267.320828] CR2: 0000000000000629 CR3: 00000004435c4002 CR4: 00000000003606f0
<4> [267.320836] Call Trace:
<4> [267.320843]  snd_hdac_bus_process_unsol_events+0x5a/0x70 [snd_hda_core]
<4> [267.320853]  process_one_work+0x245/0x610
<4> [267.320861]  worker_thread+0x37/0x380
<4> [267.320868]  ? process_one_work+0x610/0x610
<4> [267.320875]  kthread+0x119/0x130
<4> [267.320881]  ? kthread_park+0xa0/0xa0
<4> [267.320889]  ret_from_fork+0x3a/0x50
<4> [267.320897] Modules linked in: snd_hda_intel i915 vgem snd_hda_codec_hdmi mei_hdcp btusb btrtl btbcm x86_pkg_temp_thermal btintel coretemp bluetooth crct10dif_pclmul crc32_pclmul snd_intel_nhlt snd_hda_codec snd_hwdep snd_hda_core ghash_clmulni_intel ecdh_generic ecc snd_pcm e1000e mei_me mei ptp prime_numbers pps_core [last unloaded: i915]
<0> [267.320940] Dumping ftrace buffer:
<0> [267.320945] ---------------------------------
Comment 1 CI Bug Log 2019-08-09 11:01:30 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* WHL: igt@i915_module_load@reload-no-display - incomplete - BUG: kernel NULL pointer dereference
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6658/fi-whl-u/igt@i915_module_load@reload-no-display.html
Comment 2 Chris Wilson 2019-08-09 11:24:47 UTC

*** This bug has been marked as a duplicate of bug 111320 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.