Bug 111340 - [LLVM] DIRT 3 horrible performance when Shadows set to very high
Summary: [LLVM] DIRT 3 horrible performance when Shadows set to very high
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/radeon (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-09 16:03 UTC by Gregor Münch
Modified: 2019-09-18 20:11 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gregor Münch 2019-08-09 16:03:18 UTC
Once you set Shadows to very high in the Options Menu the game slows down. You have to use DXVK to run the game, version doesnt matter.

I already reported this last year when I was still using my Radeon HD 7970:
https://github.com/doitsujin/dxvk/issues/67#issuecomment-421925690

The game takes a nose dive from 134 to 29 fps once you switch the settings.

I tried today with my new Vega 56 and ACO:
with LLVM: 72,5 fps
with ACO: 206,3 fps

So we finally have the proof that LLVM is causing this. This might be the same problem we have with the long standing and still valid bug:
https://bugs.freedesktop.org/show_bug.cgi?id=100069
Comment 1 GitLab Migration User 2019-09-18 20:11:30 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/871.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.