Bug 111389 - DRI3 Full screen corruption regression in OpenArena
Summary: DRI3 Full screen corruption regression in OpenArena
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-13 05:42 UTC by Daniel Drake
Modified: 2019-11-19 08:02 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Photo of screen corruption (459.22 KB, image/jpeg)
2019-08-13 05:44 UTC, Daniel Drake
no flags Details
glxinfo output (144.06 KB, text/plain)
2019-08-14 03:44 UTC, Daniel Drake
no flags Details
xrandr output before launching OpenArena (724 bytes, text/plain)
2019-08-15 05:29 UTC, Daniel Drake
no flags Details
dmesg output after launching OpenArena with the corruption on-screen (69.53 KB, text/plain)
2019-08-15 05:29 UTC, Daniel Drake
no flags Details
Xorg.0.log captured after launching OpenArena with the corruption on-screen (52.49 KB, text/plain)
2019-08-15 05:29 UTC, Daniel Drake
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Drake 2019-08-13 05:42:46 UTC
When starting OpenArena fullscreen under GNOME, the screen becomes corrupt and the game is unplayable (see attached photo).

This has been reproduced on:
 1. Ubuntu Eoan 19.10 nightly using OpenArena from Flathub
 2. Ubuntu Eoan 19.10 nightly using OpenArena from Ubuntu packages after configuring it to enter fullscreen mode
 3. Endless OS 3.6.2 using OpenArena from Flathub

The same tests on machines that use i915 or amdgpu graphics do not reproduce the problem.

Back on the radeon device, I also found the problem does not occur if you first use xrandr to change display mode to 640x480 (so that running the game does not require it to change the display mode). Alternatively, configure it as:
   Option "DRI" "2"
and the issue is fully avoided (even when the game changes the display mode during launch)

This worked fine on older distro versions, so it appears to be a recent regression and I bisected it down to:

55e513b978b2afc52b7cafc5bfcb0d1dc78d75f6 is the first bad commit
commit 55e513b978b2afc52b7cafc5bfcb0d1dc78d75f6
Author: Michel Dänzer <michel.daenzer@amd.com>
Date:   Sat Apr 29 17:05:58 2017 +0900

    Use reference counting for tracking KMS framebuffer lifetimes


Please let me know how we can help debug further.
Comment 1 Daniel Drake 2019-08-13 05:44:07 UTC
Created attachment 145043 [details]
Photo of screen corruption
Comment 2 Michel Dänzer 2019-08-13 09:59:53 UTC
Please attach the corresponding Xorg log file.

(In reply to Daniel Drake from comment #0)
> This worked fine on older distro versions, so it appears to be a recent
> regression and I bisected it down to:

That change is over 2 years old, not exactly "recent". :)

Does it still happen with xf86-video-ati 19.0.1 or current upstream Git master?


P.S. Removing myself from CC, two copies of each notification from the mailing lists is plenty.
Comment 3 Michel Dänzer 2019-08-13 10:00:55 UTC
Please attach the output of glxinfo as well.
Comment 4 Daniel Drake 2019-08-13 10:03:15 UTC
Yes it still happens with git master and the 19.0.1 release.
I'll post the glxinfo output tomorrow. Thanks for the quick response.
Comment 5 Michel Dänzer 2019-08-13 10:08:31 UTC
(In reply to Daniel Drake from comment #0)
> This worked fine on older distro versions, [...]

How much older? The commit you bisected to would have been included as of Ubuntu 17.10.
Comment 6 Daniel Drake 2019-08-13 10:12:28 UTC
Endless-3.5.x (and also Debian Buster which was the base for that) has xf86-video-ati-7.8.0 and it works fine there.
Comment 7 Daniel Drake 2019-08-13 10:13:20 UTC
Sorry, I meant Debian Stretch
Comment 8 Daniel Drake 2019-08-14 03:44:08 UTC
Created attachment 145054 [details]
glxinfo output
Comment 9 Michel Dänzer 2019-08-14 12:11:05 UTC
Don't forget to attach the Xorg log file as well, and the output of dmesg (captured after reproducing the problem) and xrandr (captured before reproducing the problem) for good measure.
Comment 10 Daniel Drake 2019-08-15 05:29:00 UTC
Created attachment 145066 [details]
xrandr output before launching OpenArena
Comment 11 Daniel Drake 2019-08-15 05:29:24 UTC
Created attachment 145067 [details]
dmesg output after launching OpenArena with the corruption on-screen
Comment 12 Daniel Drake 2019-08-15 05:29:40 UTC
Created attachment 145068 [details]
Xorg.0.log captured after launching OpenArena with the corruption on-screen
Comment 13 Martin Peres 2019-11-19 08:02:23 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-video-ati/issues/184.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.