Bug 111399 - Freeze after suspend/resume with kernel 5.0
Summary: Freeze after suspend/resume with kernel 5.0
Status: RESOLVED DUPLICATE of bug 110258
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-14 09:33 UTC by Vladimir
Modified: 2019-08-14 11:31 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
blackscreen bug log (404.26 KB, text/x-log)
2019-08-14 09:33 UTC, Vladimir
no flags Details
amdgpu_job_timedout error log (228.65 KB, text/x-log)
2019-08-14 09:34 UTC, Vladimir
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir 2019-08-14 09:33:02 UTC
Created attachment 145058 [details]
blackscreen bug log

System: HP 15-bw660ur
GPU: Radeon 520 (Sun XT)

Screen freezes after resuming from suspend. Here is discussion of this bug - https://bugs.archlinux.org/task/61950.

I made a bisection in branch linux-5.0.y between the tags v5.0-rc1 and 4.20. I found that there are two bugs with the screen after resuming from suspend. The first bug is the one that is present in the kernel v.5 now and earlier to version 5.0-rc1. There is a bug with amdgpu_job_timedout in the log. The second is the black screen after resuming from suspend and the absence of the amdgpu_job_timedout error in the log.
The second bug first appears in commit [262485a50fd4532a8d71165190adc7a0a19bcc9e] drm/amd/display: Expand dc to use 16.16 bit backlight.
The first bug with amdgpu_job_timedout first appears in the commit [106c7d6148e5aadd394e6701f7e498df49b869d1] drm/amdgpu: abstract the function of enter/exit safe mode for RLC.
During the bisect searching for the first error, I went through the following stages sequentially: good (resuming from suspend was successful), error 2, good, error 2, error 1.
Comment 1 Vladimir 2019-08-14 09:34:37 UTC
Created attachment 145059 [details]
amdgpu_job_timedout error log
Comment 2 Vladimir 2019-08-14 11:31:42 UTC

*** This bug has been marked as a duplicate of bug 110258 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.