Bug 111415 - BUG: kernel NULL pointer dereference - supervisor read access in kernel mode
Summary: BUG: kernel NULL pointer dereference - supervisor read access in kernel mode
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-18 04:36 UTC by Tom Seewald
Modified: 2019-10-03 04:14 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg of freeze (84.64 KB, text/plain)
2019-08-18 04:36 UTC, Tom Seewald
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Seewald 2019-08-18 04:36:39 UTC
Created attachment 145088 [details]
dmesg of freeze

Distribution: Fedora 30
Kernel: 5.2.8
Mesa: 19.1.4
GPU: RX 560

Problem:
While browsing the internet using Chromium my entire machine froze, it was completely unresponsive to input but audio continued to play.


Snippet of BUG:

[173497.820810] BUG: kernel NULL pointer dereference, address: 00000000000002b4
[173497.820815] #PF: supervisor read access in kernel mode
[173497.820817] #PF: error_code(0x0000) - not-present page
[173497.820818] PGD 0 P4D 0 
[173497.820822] Oops: 0000 [#1] SMP PTI
[173497.820825] CPU: 2 PID: 21197 Comm: kworker/u8:2 Not tainted 5.2.8-200.fc30.x86_64 #1
[173497.820826] Hardware name: To Be Filled By O.E.M. To Be Filled By O.E.M./Z77 Extreme4, BIOS P2.90 07/11/2013
[173497.820839] Workqueue: events_unbound commit_work [drm_kms_helper]
[173497.820953] RIP: 0010:dc_stream_log+0x6/0xb0 [amdgpu]

See attached dmesg for full message.

Let me know if you need any additional information.
Comment 1 Tom Seewald 2019-08-18 20:53:50 UTC
This bug report on the kernel bugtracker appears to be the same or at least a very similar problem:
https://bugzilla.kernel.org/show_bug.cgi?id=204181

In that report, Nicholas Kazlauskas posted a possible fix:
https://patchwork.freedesktop.org/series/64505/

I have yet to test to see if this patch resolves the crashes I am experiencing, but I don't see this as being in the 5.3-rc series, and certainly not in the 5.2 stable releases. Was this fix perhaps overlooked/missed?

So far I just see that it is in amd-staging-drm-next as of August 1st:
https://cgit.freedesktop.org/~agd5f/linux/commit/?h=amd-staging-drm-next&id=a4f6a4c7de97335f3452229e67521eae338af10e
Comment 2 Tom Seewald 2019-10-03 04:14:58 UTC
The patches mentioned earlier have landed in 5.4 and 5.3.2, and after running 5.4-rc1 for several days now I have been unable to reproduce the crash.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.