Bug 111416 - 4k 60hz on RX 560 over HDMI = no sound
Summary: 4k 60hz on RX 560 over HDMI = no sound
Status: NEW
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-18 09:50 UTC by Alfie Day
Modified: 2019-08-19 09:49 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg log (41.50 KB, text/x-log)
2019-08-19 08:21 UTC, Alfie Day
no flags Details
dmesg (66.05 KB, text/plain)
2019-08-19 08:22 UTC, Alfie Day
no flags Details
dmesg (with hotplugging) (65.06 KB, text/plain)
2019-08-19 09:49 UTC, Alfie Day
no flags Details
Xorg log (with hotplugging) (54.74 KB, text/x-log)
2019-08-19 09:49 UTC, Alfie Day
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alfie Day 2019-08-18 09:50:22 UTC
Hi,

If I switch to 4k 60hz on my RX 560, sound instantly drops out.

I can enable/disable sound by running
`xrandr --output HDMI-A-0 --mode 3840x2160 -r 30`
`xrandr --output HDMI-A-0 --mode 3840x2160 -r 60`

No messages appear in dmesg or Xorg log when switching between 30/60hz. So I'm not sure what information to provide with aiding debugging. Please let me know!

I'm using a custom modeline since 4k 60hz option is unavailable by default (see bug #111412) this is the modeline I am using:

Modeline     "3840x2160" 594  3840 4016 4104 4400  2160 2168 2178 2250 +hsync +vsync
Comment 1 Alfie Day 2019-08-18 16:11:11 UTC
For reference, my X version is 1.20.5
My Kernel is 5.2.8-arch1-1-ARCH
My Mesa version is 19.1.4
Comment 2 Alex Deucher 2019-08-18 18:34:46 UTC
Please attach your xorg log (if using X) and your dmesg output.  What kernel are you using?  You monitor only supports 4k60 at yCbCr 4:2:0 encoding:
VIC 107 3840x2160@60Hz 64:27  HorFreq: 135000 Hz Clock: 297.000 MHz
Your custom modeline uses RGB encoding so probably uses too much bandwidth.
Comment 3 Alfie Day 2019-08-19 08:21:44 UTC
Created attachment 145089 [details]
xorg log

Log of starting X (at 4k30hz) and then increasing to 4k 60hz
Comment 4 Alfie Day 2019-08-19 08:22:21 UTC
Created attachment 145090 [details]
dmesg

Log of dmesg, starting at 4k 30hz and increasing to 4k 60hz
Comment 5 Alfie Day 2019-08-19 08:28:04 UTC
Thanks for getting back to me, I'm using this one right now: https://aur.archlinux.org/packages/linux-amd-staging-drm-next-git/

I have tested on Arches standard kernel (5.2.8) and LTS kernel (4.19.67) all of which have the same issue.

Apologies if this is user error. Sounds like you could be correct about my modeline. I tried generating modelines using cvt and gtf but I couldn't get xrandr to apply them (I'd get "xrandr: Configure crtc 0 failed" when I tried)

After much digging I found this post, https://bugs.freedesktop.org/show_bug.cgi?id=104412#c14 and I'm using that solution currently to get 4k 60hz.
Comment 6 Alfie Day 2019-08-19 09:49:06 UTC
Hi, based on your comment I went and plugged my nvidia machine into the TV using the same cable and port. I then used xvidtune -show to extract the modeline it was using: "3840x2160"   593.41   3840 4016 4104 4400   2160 2168 2178 2250 +hsync +vsync

I applied that modeline to the machine with the RX 560 in it, and still no sound. However, I made a weird discovery while switching the cable between the two machines. If I switch to 4k 60hz on the RX 560, then I pull the HDMI cable out, and plug it back in again, I get sound at 4k 60hz. So that works as a workaround. If I reboot, no sound again.

I have elimniated pulseaudio as a possibility by running

pasuspender -- speaker-test --nloops=1 --channels=2 --test=wav --device=hw:1,9

At 30hz, it works, at 60hz, it doesn't (Unless I replug the cable, then it does)

I am attaching new dmesg and Xorg logs. Booting at 60hz (and thus having no sound) and then replugging the HDMI cable (which gets me sound)

I can also simply turn my TV off and on again instead of unplugging / replugging the cable, sound also works if I boot the computer with the TV off, and then turn the TV on after X has started.
Comment 7 Alfie Day 2019-08-19 09:49:32 UTC
Created attachment 145091 [details]
dmesg (with hotplugging)
Comment 8 Alfie Day 2019-08-19 09:49:57 UTC
Created attachment 145092 [details]
Xorg log (with hotplugging)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.